IMAP email in iPhone 4.0 beta

Discussion in 'iPhone' started by j-a-x, Apr 10, 2010.

  1. j-a-x macrumors 65816

    j-a-x

    Joined:
    Apr 15, 2005
    Location:
    Houston, Texas
    #1
    I was just wondering if any other devs out there have had problems with IMAP email on their iPhone with OS 4.0 beta 1 on it? After restoring to the beta image and setting up my IMAP account (a university email account), when I go to check my email it tells me there are X new messages and to click to load more messages from the server (as if it has already displayed the first 25), but it never retrieves anything. It just attempts to load new mail for a few seconds and then stops. It will display all of my IMAP folders but it will not load the contents of them.

    Setting up the same account via POP seems to work fine

    Anybody else noticed this issue? I know it's a beta but I was curious if this was a common issue or not.
     
  2. skythefly13 macrumors 6502

    Joined:
    Mar 8, 2005
    #2
    Me too! I can't figure out why it won't show up.
     
  3. j-a-x thread starter macrumors 65816

    j-a-x

    Joined:
    Apr 15, 2005
    Location:
    Houston, Texas
    #3
    It's interesting that this bug has not been widely reported yet
     
  4. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
  5. j-a-x thread starter macrumors 65816

    j-a-x

    Joined:
    Apr 15, 2005
    Location:
    Houston, Texas
    #5
    Weird that it works for some and not for others. There's nothing different about my IMAP server. It works fine in iPhone 2.0/3.0 and OS X with every version of Mail.app I've tested it with.

    In iPhone 4.0 it lists the number of new messages and has the "Load More Messages..." button that you normally see at the bottom of an IMAP folder with more than 25 messages (or whatever you set it to be) but never loads the actual messages, not even the message headers. It just shows a blank inbox or an empty folder with the Load More Messages thing.

    I hope Apple notices that IMAp is broken for some people and fixes it before the final release.
     
  6. 4np macrumors 6502a

    4np

    Joined:
    Feb 23, 2005
    Location:
    The Netherlands
    #6
    I frequently have this issue with iPhone OS 3.1.3 as well. On my MBP I have a rule set for some e-mails to delete them immediately (svn commit mail), however, when my MBP checks the mail first and erases the messages, my iPhone keeps saying I have email in there even though there is not. My workaround is to make all emails in my inbox 'unread' on my MBP, have my iPhone check for mail, then make then all 'read' in my MBP and make my iPhone check for mail. This often helps. When it doesn't, I remove the account from my iPhone, connect to my MBP and sync the accounts back to my iPhone.

    Does this help for you as well?
     
  7. Squuiid macrumors 6502a

    Squuiid

    Joined:
    Oct 31, 2006
    #7
    Slightly off topic, but I can't get Exchange 2003 to sync at all in 4.0. Not IMAP, but defo an email issue and seems there are quite a few in this beta.
     
  8. ogdogg macrumors 6502

    Joined:
    Jun 26, 2008
    Location:
    Arizona
    #8
    IMAP is working fine with my gmail account on a 4.0 3GS.
     
  9. skythefly13 macrumors 6502

    Joined:
    Mar 8, 2005
    #9
    It's working for my IMAP Gmail account also. But not my university email. No idea, it still shows it has 1,000+ messages on the server but it just doesnt download them...
     
  10. j-a-x thread starter macrumors 65816

    j-a-x

    Joined:
    Apr 15, 2005
    Location:
    Houston, Texas
    #10
    Interesting that Gmail IMAP works but generic IMAP does not work. Hopefully Apple is testing this with more than just Gmail. Gmail might be the most popular IMAP email out there but it's not the only one...

    I've everted my phone back to 3.1.3 by the way. I'm a poor student developer who can't afford a second phone for development purposes. I'll check out the next beta when it's out though.
     
  11. j-a-x thread starter macrumors 65816

    j-a-x

    Joined:
    Apr 15, 2005
    Location:
    Houston, Texas

Share This Page