IMEI, ICCID, Modem Firmware all blank. How to restore?

Discussion in 'Jailbreaks and iOS Hacks' started by Dale Cooper, Jul 26, 2009.

  1. Dale Cooper macrumors regular

    Dale Cooper

    Joined:
    Sep 20, 2005
    #1
    Hi,
    I've been trying for some time to get redsn0w/ultrasn0w to unlock my 3g 3.0. In the beginning, I could get service for a few seconds at least. The phone would also switch randomly between "no service" and "No sim" if I removed the sim card.

    After several attempts, I now have no service, get a "restore needed" message regularily and in the about screen, my IMEI, ICCID, and Modem Firmware fields are all blank. I never get the "no sim" message, only "no service" or "searching". My impression is that initially, there was a problem with ultrasn0w, but that all my restores and jailbraking have broken something else.

    Is there anything I can do to restore this thing back to a working state? It seems like the whole modem firmware is deleted/corrupted. A couple of times, the IMEI/ICCID and Modem Firmware have appeared for a while, only to disappear if I reboot. Can this be fixed, or is it some hardware error? The fact that the phone only detects that the sim is missing sometimes (lately, it doesn't notice at all) has led me to belive something might be wrong with the hardware... Also, when restoring with an unsupported sim, is the "restore needed" message supposed to appear before the phone is jailbroken, or does this indicate that something has gone wrong with the restore?
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    Put it into DFU mode and restore in iTunes, that will get it back to its "out of the box" state. If it cures those problems then it's probably not a hardware fault.

    How to do DFU: http://www.youtube.com/watch?v=ofpinyGlQ8I
     
  3. Dale Cooper thread starter macrumors regular

    Dale Cooper

    Joined:
    Sep 20, 2005
    #3
    Tanks for the advice! I've tried that several times, but it doesn't help. If the modem firmware is blank, does that mean I could try to install 2.2 and see if that works?

    Edit:
    iTunes came up with error 1600 when I tried to restore to 2.2. Restored to 3.0 again and used redsn0w. Install Fuzzyband through Cydia, and it shows the following info:

    Bootloader 05.09 [G2M3S2]
    Baseband ICE2-04.26.08
    OS 3.0

    But the "Modem firmware" is still blank.

    Any advice???? I'm getting really desperate (and upset)!!!!!!!!
     

Share This Page