IMessage activation error while abroad

Discussion in 'iOS 11' started by Chparigi, Jul 7, 2017.

  1. Chparigi macrumors member

    Joined:
    May 25, 2013
    Location:
    Denmark, Europe
    #1
    I’m currently in Nepal as a volounteer, where I have bought a Sim-card, and put it into my iPhone. Everything works like a charm, the 3G is super fast, but I still keep getting the famous iMessage activation error, or just waiting to activate.

    I’ve tried restarting the phone, logging in and Out Of the apple-ID, turning messages on and off, reinserting the sim-card, etc., but still there is nothing happening!

    My old Danish number is still greeted out in the settings, while I have put my new Nepali number into phone-settings.

    I really hope this isn’t a bug with iOS 11. I haven’t really found a solution that works so far, maybe because I’m in Nepal?
     
  2. niji macrumors 6502a

    niji

    Joined:
    Feb 9, 2003
    Location:
    tokyo
    #2
    i switch SIMs 1 or 2 times per week visiting various countries in SE Asia (not Nepal).

    up to 2 years before there were constant problems as you have now, but these have been worked out on apple's side for the most part.

    i actually think that it in fact might be an iOS 11 caused problem for you, but here are some things/routines that have worked for me in the past:

    1 make sure there are no other devices in the entire world simultaneously signed in with your apple id.

    2 on iCloud.com sign out of all browsers

    3 if you have a mac anywhere in the world, sign out of FaceTime and Messages.

    4 go back and remove your manually entered phone number in your iPhone. manually entering it does not actually help anything. on the other hand, if your mobile number is showing up there automatically that fact by itself is useful information.

    5 are you using Ncell in Nepal as your carrier? if not, that is the one you should be using as Ncell is confirmed as compatible

    6 on iPhone, go to Cellular/Cellular Data Options/Network and verify that your Internet setting is correct. ask Ncell for the settings to enter here (sorry if the word Network isn't correct. I'm in a country currently where that setting is not appearing on my iPhone right now since for this current carrier I am now enters that setting automatically and that option doesn't appear on my phone right now. this is from memory when I am in countries using carriers where the setting is not done automatically) if you can't get the info, try to put " internet " without quotes as that is the default wording for many carriers.

    7 sign out of iMessages and FaceTime both on your iPhone

    8 sign in to FaceTime. and see if doing that gets you FaceTime access. i recommend FaceTime before iMessages because it seems to be the easier of the two to get working, and once one of them works, the other one also will work within minutes.

    9 sign back into iMessages. check if your local mobile number is now showing.
    look at it to see if it is all black with a check mark, or doesn't appear at all, or, shows the correct number but is greyed out, possibly with a spinning mark to indicate still attempting to verify

    10 if the number is not appearing at all, then the problem is most likely your current carrier has some sort of problem, or your SIM number is not recognizable. in which event you need a different SIM

    11 if your number is greyed indicating attempting to verify then Reset your Network (warning Network settings will be lost) General/Reset/Reset Network Settings.

    12 check iMessage.

    13 even if still greyed out, for me at this point it is just a matter of time before iMessage becomes usable. from minutes to 5 or 6 hours.

    sorry if none above doesn't help in your situation...
     

Share This Page