iMessage and FaceTime won't activate

Discussion in 'iPhone' started by MyRomeo, Sep 22, 2012.

  1. MyRomeo macrumors 6502


    Jul 22, 2010
    United Kingdom
    Just upgraded from ip4 to ip5 with no problem at all. Give the wife my 4 to replace her 3GS and I can't get iMessage or FaceTime to activate, both just say waiting for activation. Tried clean install, restore from backup, restore from iCloud none work. Any idea?!
  2. tcb9289 macrumors member

    Mar 11, 2011
    I'm having the same issue! My FaceTime and iMessage were working great on iPhone 5, but today I called AT&T to resolve an issue with my imei and lte, and they're "fix" broke visual voicemail, iMessage, & FaceTime.
  3. tcb9289 macrumors member

    Mar 11, 2011
    Over on the apple support page (), they list the following solutions:

    [After each step toggle FaceTime and iMessage off and then on in Settings > Messages and Settings > FaceTime.]

    1. Update to the latest version of iOS.
    2. Verify that you are connected to a cellular network and can send SMS messages. You need a valid SMS messaging plan to activate FaceTime.
    3. Ensure that FaceTime has not been restricted: Settings > General > Restrictions > FaceTime.
    4. In Settings > General > Date & Time, ensure that Set Automatically is on. If Set Automatically is on, but the incorrect time zone is displayed, turn Set Automatically off and then choose the correct time zone, date, and time. Then turn Set Automatically on again.
    5. Contact your carrier to verify that there are no restrictions on text messages. Blocks on text messaging will prevent iMessage and FaceTime registration.
    6. If you are unable to activate iMessage or FaceTime on a device after remote wiping it, wait at least 24 hours and try again.

    I'm chatting with at&t tech support now, but it seems like (for me at least) the problem is on the carrier end. When they worked on my account earlier today, they completely messed up all my data related features. This is actually very typical for at&t.

    I hope this helps!
  4. galenmd macrumors regular

    Sep 11, 2008
    I spent hours on this today. A high level Apple tech told me that she was familiar with the issue and the only solution was to do a total restore. I did that and it solved my problem. What a total PTA though.
  5. tcb9289 macrumors member

    Mar 11, 2011
    Yeah, that's pretty much what happened with me. Hours wasted dealing with my carrier, then with apple support . . .in the end a total restore did it for me as well.
  6. johnothy macrumors regular


    Mar 10, 2012
    I can't get iMessage to work on my Macbook with my phone number. It never accepts it for some reason.
  7. VivaLaFisica macrumors regular

    Sep 17, 2012
    Setting the time to set automatically fixed it for me; thanks!

Share This Page