iMessage annoyance.

Discussion in 'iPhone' started by Gix1k, Dec 26, 2011.

  1. Gix1k, Dec 26, 2011
    Last edited: Dec 26, 2011

    Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #1
    I use iMessage on my iPhone and iPad..when I text my GF, it comes in as separate contacts from me, so she has two convo threads. When she replies, it comes to both of my devices. I got her an iPad for Xmas and when she texts me, I get the same thing on my iPhone.
    Seems like there has to be a way to merge the threads.
     
  2. Roessnakhan macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    ABQ
    #2
    Is your Caller ID on iMessage set to your phone number or AppleID?
     
  3. Gix1k thread starter macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #3
    I've never changed that. Don't even know where it is. Inform me please.
     
  4. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #4
    That's happening because on your phone your caller ID as Roessnakhan said is your phone number but on your iPad it's your Apple ID. The way to change this is to have your caller ID on your iPhone set to your Apple ID as well.

    Go to Settings > Messages > Receive at > Caller ID > Pick your email
     
  5. Gix1k thread starter macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
  6. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #6
    You're welcome :D

    I love it too. It's usually really helpful and I find out a lot of things just by reading what other people say. Sometimes some people are obnoxious but that's not gonna stop me from coming here
     

Share This Page