iMessage: email vs phone number?

Discussion in 'iPhone' started by orange42, Mar 21, 2012.

  1. orange42 macrumors 6502a

    Apr 12, 2009
    How does iMessage decide when to send messages from either my email address or my phone number? Some of my friends receive them from my phone number, and some receive them from my email address. How does this work?
  2. zachlegomaniac macrumors 6502a


    Sep 20, 2008
    Under "Settings" and then "Messages" on each device (in this case, your iPhone) you should be able to enter your preference. I believe the iPhone defaults to your phone number, but as I am using Messages Beta now instead of iChat, I typically send from my .me account when talking to other friends with iOS or OSX devices.

    The reason I do this is for the continuity of conversations across devices.

    Check out your settings under "Receive At" under the messages preferences on your iPhone.

    I hope my limited knowledge and experience helps a bit.
  3. orange42 thread starter macrumors 6502a

    Apr 12, 2009
    I know mine is under receive at 2 addresses, email and phone, but I can't change the options between the two, and I just want to know what makes it sometimes send from my email and sometimes from my phone.
  4. TheAppleSource macrumors regular


    Mar 9, 2012
    United Kingdom
    Do you have the Called ID option underneath the "Receive at..." set of options? Try changing that to your phone number (or email) and see if that changes things.
  5. orange42 thread starter macrumors 6502a

    Apr 12, 2009
    It's set to my phone number.
  6. cynics macrumors G4

    Jan 8, 2012
    Maybe try removing your email temporarily and sending the people that get your email address another text to see what happens.

    It sounds that mine is setup the same way as yours but I don't have that issue.

    Do those people have your number in their phones? Maybe all they have is your email?
  7. saving107 macrumors 603


    Oct 14, 2007
    San Jose, Ca
    I believe that after 5 or 10 minutes of trying to send an iMessage unsuccessfully, the iMessage will then be sent as a regular text (which will then appear as your phone number).

    Thats why I set mine to OFF.


Share This Page