iMessage iCloud Deletion Issue

Discussion in 'macOS High Sierra (10.13)' started by moabal, Jun 1, 2018.

  1. moabal macrumors regular

    Joined:
    Jun 22, 2010
    #1
  2. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #2
    Everyone who has not updated macOS to version 10.13.5 has the same issue. The fix is to update your Mac to 10.13.5, which include Messages in the Cloud Support.
     
  3. moabal thread starter macrumors regular

    Joined:
    Jun 22, 2010
    #3
    I have updated to 10.13.5. I enabled iCloud in iMessage settings on my Mac. This thread is because I am having this issue on the new version. Can you replicate the issue?
     
  4. RyanXM macrumors regular

    RyanXM

    Joined:
    Jul 7, 2012
    Location:
    DFW, TX
    #4
    The update has been out around 2 hours. I would give iCloud a chance to catch up, both on your account as well as the server load. If the issue persists over the next day or so, I would log out of iCloud on your Mac and log back in.
     
  5. Sdtrent macrumors member

    Sdtrent

    Joined:
    Feb 15, 2017
    #5
    I'm having this same problem! Deleting messages from my Macs does not result in the message being deleted everywhere else. Is this how its supposed to be? I'm running macOS 10.13.5 and iOS 11.4.
     
  6. moabal thread starter macrumors regular

    Joined:
    Jun 22, 2010
    #7
    Let me know if this resolves itself for you. Would be very interested.
     
  7. Sdtrent macrumors member

    Sdtrent

    Joined:
    Feb 15, 2017
    #8
    Hey it just started working! I didn't do anything special, just waited for a bit :)
     
  8. moabal thread starter macrumors regular

    Joined:
    Jun 22, 2010
    #9
    So to be clear, you creating a message for yourself and deleted on your Mac and just waited for it to delete on your other iDevices?
     
  9. Sdtrent macrumors member

    Sdtrent

    Joined:
    Feb 15, 2017
    #10
    Ya its all working now. Also, it turns out there was a setting that was keeping it from working on my iMac. Open up the Messages app and go to Preferences. Under the General tab, make sure that "Save history when conversations are closed" is unchecked. After that it should start working when you try to delete a message conversation on your Mac.
     
  10. moabal thread starter macrumors regular

    Joined:
    Jun 22, 2010
    #11
    That fixed it! Thank you.
     
  11. Chris Grande macrumors regular

    Chris Grande

    Joined:
    Jun 17, 2003
    #12
    Basically the Mac has the the ability to "hide" a conversation, while on iOS you can only delete...
     
  12. walex19 macrumors regular

    walex19

    Joined:
    Jun 28, 2010
    Location:
    Atlanta,GA
    #13
    All you need to do is enable messages in iCloud under preferences (iMessage) on the mac.
     
  13. donawalt macrumors regular

    donawalt

    Joined:
    Sep 10, 2015
    #14
    For the record, this is not needed, it just may have been timing that it started working for you. From the first that I turned on the setting for messages in iCloud, it started working - I specifically tested deleting a message and saw it instantaneously get deleted from my phone - and I do not have the "Save history when conversations are closed" checked at all.
     
  14. moabal thread starter macrumors regular

    Joined:
    Jun 22, 2010
    #15
    I did another test with it on and off. It only seems to work with it off.
     

Share This Page