iPhone X iMessage isn’t working ?

Discussion in 'iPhone' started by Closingracer, May 29, 2018.

  1. Closingracer macrumors 68040

    Joined:
    Jul 13, 2010
    #1
    I recently bought an iPhone X coming from my Note 8 . I decided to get onto a family plan with a friend so save some cash and decided to go back with apple since I found battery life to be horrible on my note 8 . So anyways I also switch carriers from Verizon to sprint and haven’t yet been able to send iMessage yet only sms
     
  2. Banglazed macrumors 68020

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #2
    Try these and toggle iMessage off then on. Sometimes, it takes 10 minutes to activate
    1. Must have a valid SIM card with active plan with cellular or WiFi on
    2. Remove and re-seat the SIM card
    3. Settings>General>Reset>Reset Network Setting
     
  3. Closingracer thread starter macrumors 68040

    Joined:
    Jul 13, 2010
    #3
    Seems to me it’s choosing not to do it with one of my contacts which is weird .
     
  4. Banglazed macrumors 68020

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #4
    If it is just one contact, does he or she is using iMessage? It's possible he or she is in a low cellular data area and he/she couldn't receive it and the device switches iMessage to SMS so attempt to deliver it.
     
  5. Closingracer thread starter macrumors 68040

    Joined:
    Jul 13, 2010
    #5
    Yes . He’s my friend who I am on a family plan with and did iMessage before when I had an iPhone prior to my note 8
     
  6. Closingracer thread starter macrumors 68040

    Joined:
    Jul 13, 2010
    #6
    So it seems I can iMessage him on my MacBook Pro but still goes back to SMS on my phone. Only person with an iPhone I am having this issue with
     
  7. ericwn macrumors 68020

    Joined:
    Apr 24, 2016
    #7
    Maybe iMessage works when using his email address rather than a phone number?

    Also make sure your contact on the device has both email and phone number entered.
     
  8. Closingracer thread starter macrumors 68040

    Joined:
    Jul 13, 2010
    #8
    Ok never had this issue with my iPhone 7 with him . Only thing changed was my phone number
     
  9. Banglazed macrumors 68020

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #9
    Are you signed into your iCloud for iMessage?

    You can try these as well:
    1. Backup or forward your said contact messages. Delete the entire thread. Delete the contact and re-create it.
    2. Sign out of iCloud under Settings>Messages>Send & Receive or deselect all other and use only your phone number. Your old phone number may be shown here too.
     
  10. Closingracer thread starter macrumors 68040

    Joined:
    Jul 13, 2010
    #10
    I’ll check those out but I know my old number is gone
     
  11. Closingracer thread starter macrumors 68040

    Joined:
    Jul 13, 2010

Share This Page