iMessage name@name.com

Discussion in 'iPhone' started by Melodeath, Aug 5, 2012.

  1. Melodeath macrumors 6502a

    Joined:
    Dec 9, 2009
    #1
    Ok I've been texting a friend lately and everything has been normal. Her phone number is in my phone as a contact and when she texts me it shows up as her name, and the messages are typically iMessages, with the occasional green "Sent as Text."

    Then last night suddenly all our texts were green, and not iMessages. I figured it's because she is in a place with no WiFi.

    Then I got a text from [her first name]@[her last name].com and it's all iMessages. This is a separate conversation thread than the contact for her phone number, but she says she is texting from her phone as usual.

    Any ideas why this has happened? All my iMessages with other friends are working as normal, so I assume it's something with her phone, but it's annoying that this contact has suddenly become two contacts in my phone instead of one.
     
  2. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #2
    Sounds like some settings changed on her end somehow; she isn't set to receive iMessage via phone number anymore.
     
  3. Melodeath thread starter macrumors 6502a

    Joined:
    Dec 9, 2009
    #3
    Do you think if I add that email address to her normal contact entry in my phone, all of the new texts will merge to the previous message thread?
     
  4. AAPLinc macrumors 65816

    Joined:
    Jul 27, 2012
    Location:
    Hollywood, CA
    #4
    Yes, this happened to me when I first got my 4S and started using iMessage. She has to set her phone to send/receive messages at her number and not her email address.
     
  5. Melodeath thread starter macrumors 6502a

    Joined:
    Dec 9, 2009
    #5
    Ok so, under Settings>Messages>Receive At she has both her phone number and email listed. And under Caller ID the checkmark is next to her number, not her email. She has tried turning off iMessages, then turning it back on, and turning the phone off and on, but iMessages are still coming from her email to me and other people.

    Anyone have any ideas?
     
  6. MacFan23 macrumors 6502

    Joined:
    Feb 17, 2010
    #6
    Which thread are you responding to the name@name.com or the number?
    Could it be as simple as you replying in the name@name.com thread?
     
  7. Melodeath thread starter macrumors 6502a

    Joined:
    Dec 9, 2009
    #7
    When it's a text it comes through on the number and I reply there. When it's an iMessage it comes through as the email, and I reply to that thread instead.

    Again, this only started a couple of nights ago. before, texts and iMessages were in the same thread.
     
  8. MacFan23 macrumors 6502

    Joined:
    Feb 17, 2010
    #8
    How about if she goes to settings -> Messages and signs out?
     
  9. Melodeath thread starter macrumors 6502a

    Joined:
    Dec 9, 2009
    #9
    Hmm, I am not seeing that option under Messages. Do you mean turning iMessage off then on? That requires a re-login.
     
  10. MacFan23 macrumors 6502

    Joined:
    Feb 17, 2010
    #10
    I mean just leaving it off without signing into an Apple ID
     
  11. dccorona macrumors 68020

    dccorona

    Joined:
    Jun 12, 2008
    #11
    This is a known issue, it's got to do with the (bad) way apple handles email-based iMessages. They claim that will be fixed in iOS 6...you'll be able to bind a phone number to your apple account and set it as your primary ID, so it shows up as from your number even when sent from a mac, iPad, or iPod. Any message sent from any of your IDs or to any of your IDs will appear in the same thread in both your and the senders/receivers message box.

    So they claim...I hope it works that seamlessly, as that's what I was envisioning/hoping for with the original iMessage
     
  12. Melodeath thread starter macrumors 6502a

    Joined:
    Dec 9, 2009
    #12
    It's a known issue? It's just really odd this spontaneously started and no setting appears to have changed to cause it
     
  13. Melodeath thread starter macrumors 6502a

    Joined:
    Dec 9, 2009
    #13
    Thought I'd update the thread and say that suddenly everything is back to normal. iMessages have started coming from her phone number again. She says she didn't do anything to the phone to fix it, so who knows what happened. :confused:
     
  14. MacFan23 macrumors 6502

    Joined:
    Feb 17, 2010
    #14
    Guess it was just some server side bug. I've had the "undelivered" one a couple of times now. Must be hard to manage that system with so many messages being sent a day.
     
  15. soLoredd macrumors 6502a

    Joined:
    Mar 12, 2007
    Location:
    California
    #15
    You don't need WiFi to send iMessages from iPhone - it still works over cellular. Probably just a server issue.

    Would be nice to have email and phone number as ONE, so I can move from my iPhone and iPad seamlessly. Hopefully iOS 6 fixes this.
     

Share This Page