iMessage Problem

Discussion in 'iPhone' started by nelford87, Dec 22, 2011.

  1. nelford87 macrumors newbie

    Joined:
    Oct 9, 2011
    #1
    Hey all.

    iMessage was working a treat a few days ago sending the messages via my phone number, but ever since I cancelled another contract with o2 (UK) and requested a PAC code, iMessage sends the message via my email which is causing confusion among my contacts. My network provider insist that the phone number transfer has been completed fine, I just can't get my contacts to view me as my new number instead of my email.

    Any ideas?

    Help appreciated.
     
  2. Jamkas, Dec 22, 2011
    Last edited: Dec 22, 2011

    Jamkas macrumors member

    Joined:
    Dec 22, 2011
    Location:
    North New Jersey
    #2
    Quite the weird problem.

    I suspect it has something to do with iCloud or iMessage not resetting to send it as your phone number, like it was an iPad or something.

    I'm a little unfamiliar with UK services. If you have a SIM card I recommend pulling it out and putting it back in and doing a hard reset. Just to see if you can force your phone to see that you are back on a carrier with a phone number.

    Try and go to Setting > Messages > Receive at

    Then add your phone number.

    Even try turning iMessage off and then back on under "Messages" where I lead you above.
     
  3. nelford87 thread starter macrumors newbie

    Joined:
    Oct 9, 2011
    #3
    Appreciate the reply. I have already done what you said and strangely enough via my settings > phone my iPhone desplays 'my number' as the correct one, but iMessage still sends via my email.
     
  4. Jamkas macrumors member

    Joined:
    Dec 22, 2011
    Location:
    North New Jersey
    #4
    Try the rest I posted. Sorry I edited the post, it probably didn't notify you.
     
  5. nelford87 thread starter macrumors newbie

    Joined:
    Oct 9, 2011
    #5
    Yeah when I look it 'Receive At' it displays as the number that I want, but all my contacts are reporting that they receive an iMessage 'from email address'.
     
  6. ecwhite4S macrumors 6502

    Joined:
    Dec 17, 2011
    Location:
    Los Angeles, CA
    #6
    This happened to my sisters iPhone 4 when she updated to 5.0.1. But it only happened for a few text messages where it was showing up coming from her email address and not her number. I'm not even sure if what happened to my sister is what you're talking about? Anyways, it went away, and now its back to normal, but it was weird.
     
  7. Jamkas macrumors member

    Joined:
    Dec 22, 2011
    Location:
    North New Jersey
    #7
    Maybe we can try this.

    Go to Settings > General > Reset > Reset Network Settings

    I've been Googling and haven't turned up anything yet. Will keep trying.
     
  8. nelford87 thread starter macrumors newbie

    Joined:
    Oct 9, 2011
    #8
    doesn't seem to have worked :(
     

Share This Page