iMessage STILL not sending through my phone number

Discussion in 'iPhone' started by Dandalph, Sep 30, 2012.

  1. Dandalph macrumors newbie

    Joined:
    Sep 14, 2012
    #1
    Hey all,

    iMessage is sending messages through my email rather than my phone number.

    I've restarted my phone and selected my phone number AFTER it was greyed out and I couldn't send anything through my phone number.

    My phone number is now checked with my email being checked as well. In settings I have "start new iMessages through my phone number" checked, however when I send a message through my phone number I never get the "delivered" message in my chat window.

    However, when using my email address it delivers without an issue.

    Anyone else experiencing this and have tips/advice to get it working?

    Again, my phone number IS checked, it wasn't before, but after a restart of my phone I was allowed to check it again.

    Thanks for any/all help - hope not TOO many people are experiencing this!
     
  2. jester0723 macrumors regular

    Joined:
    Sep 6, 2011
    Location:
    Virginia
    #2
    I got my iMessage to work with my Mac, iPad, and iPhone but it took a while. I deactivated it on all the devices and signed out of my Apple ID. Then I enabled it on the iPhone and made sure the ID was set to my phone number. Then, when I reenabled it on my other devices I re signed into my Apple ID and the phone number finally showed up.

    Basically I played around with turning it on and off and signing in and out on my 3 devices until it worked. Now it's totally worth it - I can text my friends back while I'm working on my computer or in class without even taking out my phone and the whole conversation syncs back to my phone so I don't miss anything. I love it.
     

Share This Page