imessage stopped working over wifi (abroad on airplane mode)

Discussion in 'iPhone' started by ThereGoesJB, Jan 14, 2017.

  1. ThereGoesJB macrumors regular

    Joined:
    Sep 29, 2010
    #1
    this is the second time this has happened to me, I'm in canada on airplane mode for two weeks, I've done this before while abroad and been on airplane mode the whole time and imessage works great with other iphones when I'm on wifi.

    But something has happened that causes the messages to not go through, they appear green (like normal text messages) with error icons saying "failed to send". If I say resend I get a popup message saying "turn off airplane mode or use wi-fi to send and receive messages".

    I am on wifi, I am now using facebook messager instead, but it drives me nuts that imessage cant work
     
  2. ericwn macrumors 65816

    Joined:
    Apr 24, 2016
    #2
    Maybe try to switch iMessage off in settings/Messages and then switch it on again, see if it helps. Best success!
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  4. E.Lizardo macrumors 65832

    Joined:
    May 28, 2008
    #4
    You can't have wifi and be in airplane mode by definition.
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    You can have airplane mode enabled and wifi enabled along with it (as far as how things go in iOS at least).
     
  6. E.Lizardo macrumors 65832

    Joined:
    May 28, 2008
    #6
    Ha! True! I learned something today
     

Share This Page