iMessage sync not deleting

iFoggy

macrumors member
Original poster
Apr 26, 2011
80
4
Hi,

Since I have had my iPad Pro 11 iMessage sync in terms of deleting of messages across all my devices would not work on just that device, on my iPhone & Mac it works flawlessly.

I have tried everything to restoring it with a new IPSW version, signing in / out multiple times across all devices yet still when I delete an iMessage on my iPhone or Mac it remains on the iPad.

Any ideas?

Thanks
 

gigapocket1

macrumors 68000
Mar 15, 2009
1,724
1,037
Hi,

Since I have had my iPad Pro 11 iMessage sync in terms of deleting of messages across all my devices would not work on just that device, on my iPhone & Mac it works flawlessly.

I have tried everything to restoring it with a new IPSW version, signing in / out multiple times across all devices yet still when I delete an iMessage on my iPhone or Mac it remains on the iPad.

Any ideas?

Thanks
Double check and make sure you have iCloud messages turned on. On that device.
[doublepost=1550401531][/doublepost]
Double check and make sure you have iCloud messages turned on. On that device.
Also make sure you have your email addresses unchecked under messages > send and receive.
 
  • Like
Reactions: ChaseSimon

archvile

macrumors 6502
Oct 27, 2007
463
596
iMessage sync works perfectly for me and I use an email address and phone number. Both get used and both seem to work/sync fine.
Yeah, having an email address selected shouldn’t matter. In fact, I could not get SMS relay working on my Mac without also having an email enabled, for some reason. That was during iOS 11/High Sierra days though, so it may have been a bug at the time.
[doublepost=1550426640][/doublepost]
Hi,

Since I have had my iPad Pro 11 iMessage sync in terms of deleting of messages across all my devices would not work on just that device, on my iPhone & Mac it works flawlessly.

I have tried everything to restoring it with a new IPSW version, signing in / out multiple times across all devices yet still when I delete an iMessage on my iPhone or Mac it remains on the iPad.

Any ideas?

Thanks
Messages in iCloud is disabled by default so check there first.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.