iMessage vs SMS confusion

Discussion in 'iPhone' started by JerseyDoug, Jul 24, 2012.

  1. JerseyDoug macrumors regular

    Joined:
    May 10, 2012
    #1
    I am trying to understand how this works with the iPhone.

    My daughter and I both have iPhone 4s. When she was in London and i was in the us, we texted. When she was connected via wifi the dialogue boxes were blue (iMessage) and when not they were green (SMS). She was not using a local sim (we are on Verizon).

    Recently, she went back London and Madrid. Got a local sim in London. I started receiving iMessages from her apple id. Ok, no problem. Now that she is back in the US, I have two conversations going. Now when I text her from our original thread it is green and I have to use the thread started while she was in London if I want it to be blue. On her end it is all iMessage (blue).

    Is it because that my phone now "knows" her apple id it can differentiate and does so?

    Thanks for any insight. Obviously, this is not a problem, I am just trying to understand what is going on.
     
  2. iKIKO macrumors regular

    iKIKO

    Joined:
    Jul 30, 2011
    #2
    the green must be from the phone number and the blue from the apple id. try erasing both conversations ans start again, from her id ;)
     
  3. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #3
    its going green because the user is not on data and its sent it as a normal text.
     
  4. JerseyDoug thread starter macrumors regular

    Joined:
    May 10, 2012
    #4
    Yeah. I'll just keep he conversation going on her id. I have my phone set to use SMS if iMessage isn't available.

    Thanks.

    ----------

    Don't think so. Same thing happens when I am sitting in my living room with one phone in each hand. We are on the same plan/account so both have data.
     
  5. staccato83 macrumors 6502a

    staccato83

    Joined:
    Sep 9, 2008
    Location:
    Las Vegas
    #5
    On her phone, go into Settings > Messages > Receive At > Caller ID. See if her Apple ID is selected rather than her phone number. This is why you are having two text conversations. I bet it switched to her Apple ID when she switched SIM cards.
     
  6. JerseyDoug thread starter macrumors regular

    Joined:
    May 10, 2012
    #6
    Checked already. It is on her Id. I agree. I think swapping sims caused it, but it isn't a problem. Just trying to understand. Thanks.
     
  7. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #7
    Sorry, I didn't mean you don't have a data plan. I meant the message didn't send via data and sent as a normal text.

    Looks like you've solved it anyway. :)
     
  8. SMIDG3T Suspended

    SMIDG3T

    Joined:
    Apr 29, 2012
    Location:
    England
    #8
    Hi. This may work. Try this.

    Go Settings> Messages> Recieve At.

    How many are you recieving at? If it's just your phone number add your Apple ID. Once you've done that make sure you're recieving at 2 addresses. Your phone number and your email.

    Me and my friend had the same problem. I was only recieving from my phone number and he was recieving from his email. This resulted in 2 conversations going. Once I added my email it worked fine.
     
  9. JerseyDoug thread starter macrumors regular

    Joined:
    May 10, 2012
    #9
    We are both receiving two addresses. Phone and email.

    I think it is a result of my having never had her apple id listed in my contacts until she went to London and popped in a new sim. Then she iMessages me while on wifi using her apple id.

    We never texted using her London number. She was supposed to get the sim in Madrid but didn't. So, I told her to just keep it in airplane mode. Therefore we never used SMS until her return.
     
  10. Caliber26 macrumors 68000

    Caliber26

    Joined:
    Sep 25, 2009
    Location:
    Orlando, FL
    #10
    I wish iMessage were a little more streamlined. The iOS 6 update will supposedly tie in your mobile number with your Apple ID, so that should avoid those annoying multiple threads. I'm looking forward for a more seamless experience.

    As for iMessages on my Mac, well, I just gave up on it. Getting my messages on it is very hit or miss and it doesn't sync my messages very well, so I've abandoned it until Mountain Lion is released and it's no longer in beta.
     

Share This Page