iMessage

Discussion in 'iPhone' started by testdrive, May 13, 2012.

  1. testdrive macrumors member

    Joined:
    Mar 1, 2012
    #1
    I have a friend who lives in the UK and has an iphone 4s as well. I currently use skype to message him and sometimes skype isn't on so messages don't come. So I recently found out about associating apple id to iMessage. I have my friend already as a contact in my address book (I get 50 international minutes each month so I call him occasionally). My phone company charges 25 cents for each international message texted or received. So I want to somehow set up my apple ID with this friend so when I send a message, it goes to his apple ID and won't try to send to his phone number if apple id doesn't work or his wifi is off. This would make it so much easier and the UI on iMessage is so much nicer and easier to use.

    Can someone explain to me this procedure and what settings to alternate. I don't want to pay at all and I want the message to only go to the apple id, not actual cell phone number.
     
  2. xRYD3Rx macrumors 6502

    Joined:
    Jul 3, 2010
    #2
    The only thing I know if you use iMessages it counts against your data not text messages. But if you use your email to imessage it will not charge you anything as long as your using wifi
     
  3. Kieran108 macrumors newbie

    Joined:
    May 13, 2012
    Location:
    England
    #3
    I use iMessage quite a lot and it's pretty simple when you get started. The first thing you need to do is go to settings -> messages and turn iMessage ON. To avoid being charged if something goes wrong, turn "Send As SMS" OFF. As long as your friend has an apple ID associated with the device you are trying to send a message to, you will send an iMessage. The bubble will be blue instead of green to show this. As long as you and your friend are both connected to either wifi or 3G, when you try to message the device it should just be sent as an iMessage.

    Hope this helps.
     
  4. sulpfiction macrumors 68030

    sulpfiction

    Joined:
    Aug 16, 2011
    Location:
    Philadelphia Area
    #4
    Go to settings>messages....

    Turn iMessage on

    Scroll down to "receive at" and make sure The email associated with ur apple ID is in there, rather then a phone #.

    Turn "send as SMS" off

    That's it. Simple.
     
  5. JAT macrumors 603

    Joined:
    Dec 31, 2001
    Location:
    Mpls, MN
    #5
    Your friend also has to set it up.

    Also, when you send a message the first time, don't use the old conversation thread, as that is tied to the phone number. Go into Contacts for your friend, hit Send Message, and choose the email address instead. Then make sure you use that thread in Messages from now on, and it should always be blue. (you can also start this from in Messages, I just find it easier to start with Contacts)
     
  6. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #6
    I also have friends in the UK and we use iMessage constantly as well as facetime.
    Make sure you iMessage turned on in your phone settings.
    You should not have to turn off your SMS as the iPhone will detect if the contact is using iOS first, and send as iMessage automatically. It will only send SMS if it is unable to send it via iMessage (such as he has it turned off, not connected to any data connection, etc.)
    So far, in the past 2 years, we've never had any problems with iMessage not working properly.

    Make sure he has iMessage turned on and setup with his apple id properly. Then make sure you have his number and email/apple ID in his contact info. Then when you start a message to him, you'll see the green background around his name turn to blue. Blue means its using iMessage.

    Also, if you want to make sure it only goes as iMessage you can simply enter in his apple ID and remove his phone number. This will ensure it does not go out as an SMS. Thus you do NOT have to disable send as SMS.

    Enjoy.
    Also, we've found that FaceTime is much better than skype if you have a wifi connection. But skype we still use if just 3G is available.
     
  7. Sam0464, May 13, 2012
    Last edited: May 13, 2012

    Sam0464 macrumors newbie

    Joined:
    Mar 28, 2011
    #7
    Be careful - sometimes imessage system is not working properly and you can send or receive sms instead od imessages and paying money. even if "send sms" function off is not working. if you are in US incoming sms are not free. i advice you to use some programs which are not using sms at all. see here - http://www.whatsapp.com/. i use it all the time and it works perfectly and free. you may choose any other programs. more than that your friends who do not have iphones can use it too because it is working on different mobile platforms and it's free for everyone too. you use your data only - very small of it. try it.
     

Share This Page