iMessage

Discussion in 'iOS 11' started by Sydshah, Mar 4, 2018.

  1. Sydshah macrumors newbie

    Joined:
    Sep 5, 2017
    #1
    Hi, so yesterday i tried a new sim card(vodafone) in my iPhone to test covearge but i must have pressd ok to enable iMessage however once i had used vodafone for about 15 mins I returned to my original sim(BT)
    I messaged my friend who told me that my messages were coming from
    A new number (vodafone ) i turned iMessage on/off but would now activate also it shows the vodafone number rather than the BT number even though i didnt have my vodafone sim in there. It wad showing the number greyed out with a round circle loading under that it had my email.
    I have contact applecare who made me do the usual turn on/off, sign out of icloud and change password but nothing has happened, it still says error activating iMessage and then says waiting for iMessage to activate?
    Any help would be welcome
     
  2. Banglazed macrumors demi-god

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #2
    Sometimes there is problem activating iMessage. You might try this, sign out of iCloud and iCloud from iMessage and FaceTime. Activate iMessage using phone number and sign back into iCloud after it activated
     
  3. Sydshah thread starter macrumors newbie

    Joined:
    Sep 5, 2017
    #3
    Thanks for reply but it hasn't worked, I cannot even see the reach me menu , where it shows you your number and email. , but saying that when it does show it shows the other number. It is greyed out and loading circle next to it.
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    I had a similar issue some years ago when my daughter changed her number, this resolved it then (these were probably on iOS7 and from my notes at the time:

    1) Switched off Face Time (Setting -> FaceTime-> FaceTime OFF)
    2) Switched off iMessage(Setting -> Messages->iMessage OFF)
    3) Switched on iMessage (The phone started “Verifying”the incorrect phone number, it failed and I set it to the correct number (see Settings -> Messages -> Receive At -> Phone).
    4) At this point the “My Number” (Settings ->Phone -> My Number) had also updated.
    5) Switched on Face Time (Same “Verifying” as with iMessage, but took two attempts).

    If you are still having difficulty then sign out of both iMessage AND Face Time and restart the phone, then try signing in again. If still problems retry the sign out with the Vodafone sim in the phone, then power off and reinsert the BT sim and try signing in.
     
  5. Sydshah thread starter macrumors newbie

    Joined:
    Sep 5, 2017
    #5

    Thank you i have just tried this, and it work
     

Share This Page

4 March 4, 2018