iMessages coming through as texts

Discussion in 'iPhone' started by Foxdog175, Apr 8, 2012.

  1. Foxdog175 macrumors regular

    Joined:
    Apr 3, 2008
    #1
    A friend of mine just bought an iPhone last night. For some reason, some of the texts are coming through green (Sent as Text Message) and others are coming through as blue (iMessages). Usually, the text messages come at the start of a conversation and then convert after a message or 2 into using the iMessage system.

    Is this a bug? I don't have a text messaging plan anymore specifically due to iMessage and now I'm getting randomly charged for text messages that should be using iMessage.
     
  2. dtbratt macrumors 6502

    dtbratt

    Joined:
    Feb 6, 2011
    Location:
    Grimsby, ON
    #2
    Maybe they are being sent threw his phone # and Apple ID? Or he selects your phone # or apple ID sometimes.
     
  3. Foxdog175 thread starter macrumors regular

    Joined:
    Apr 3, 2008
    #3
    I'm not following. Can you elaborate?
     
  4. SamFisher macrumors member

    Joined:
    Sep 15, 2010
    Location:
    United Kingdom
    #4
    I think the previous poster is saying, he may be selecting either your phone number, or apple id. Selecting the latter would send as an iMessage.
     
  5. NJFP macrumors 6502

    Joined:
    Feb 18, 2009
    #5
    Make sure he has his phone number set as primary in settings under messages. If he has his Apple ID email as primary, he'll get txt.
     
  6. dtbratt macrumors 6502

    dtbratt

    Joined:
    Feb 6, 2011
    Location:
    Grimsby, ON
    #6
    Let us know how you make out. Under Settings/Messages make sure the Caller ID is your Phone #. Same for your friends iPhone.
     
  7. Foxdog175 thread starter macrumors regular

    Joined:
    Apr 3, 2008
    #7
    Within settings/messages, "Receive At" should be his phone number, correct? I'll have to check with him. What makes no sense is that 90% of the conversation will be in blue and every once in a while, I'll see a "Sent as Text Message" appear under one of my messages.
     
  8. PurrBall macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #8
    It could be his network. My phone will switch to text automatically when AT&T is having problems, and switches back to iMessage when all is well.
     
  9. Sam0464 macrumors newbie

    Joined:
    Mar 28, 2011
    #9
    Try this - http://www.whatsapp.com/. You can send and receive messages within seconds, no delay, no sms.

    And forget IPhone sms\imessages problems.;) I waste a lot of money because my and my friend's imessages suddenly transfer to sms.
     
  10. Foxdog175 thread starter macrumors regular

    Joined:
    Apr 3, 2008
    #10
    I can confirm that we're both using our phone numbers in the Settings/Messages setup. I'd really like to stick with the proprietary software, but if it's buggy, I may have to use something like whatsapp :(
     
  11. Sam0464 macrumors newbie

    Joined:
    Mar 28, 2011
  12. applefanDrew macrumors 65816

    Joined:
    Jul 17, 2010
    #12
    Dude it's the network. My dad's does the same thing as you describe. But it's because he's in area with spotty coverage. No bugs...it's just if the network is to clogged it'll send as a text. You can turn that off in settings.
     
  13. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #13
    Usually the case why messages are scrambled between texts and iMessages are because 1) your phone didn't have a proper data connection to receive/send messages or 2) the other party didn't have a proper data connection to receive/sent messages.

    iMessages are generally prioritized over 3G. Whenever I turn off my 3G, messages generally come in as a text but when I reply, it gets sent as an iMessage on WiFi and the conversation generally continues as an iMessage until my phone disconnects from WiFi.

    I would ask your friend if he could turn off the "send as SMS" option. Or actually, also set up an email address to your iMessage and give him that email. tell him to create a separate contact for you with that email and to iMessage that. That way the only messages you will get from him are iMessages.
     

Share This Page