iMessages going to my phone AND my iMac....whats wrong

Discussion in 'OS X Yosemite (10.10)' started by dictoresno, Sep 17, 2014.

  1. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #1
    I'm running Yosemite and iOS8. I started getting the stupid phone calls across all my devices, a true pain in the butt. I finally got that sorted out and turned off. I only want my phone ringing. Now, out of nowhere, I'm getting some, not all, iMessages sent to my phone and my computer at the same time. iMessage is set up on my computer, but only using my email address, not my phone number. one of my contacts, using my phone number, is showing up on my phone and iMac. is there a setting I'm missing? its really starting to piss me off.
     
  2. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    Open messages and select preferences . You will see a list of numbers and/or email accounts that can send/receive messages. Edit accordingly.
     

    Attached Files:

  3. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #3
    already did that. its set up for email only, not by number. once i put my phone across the room, not next to my mac, it stopped. i wonder if its something wrong with ios8. last week, someone messaged me saying my iMessage conversation started a whole new convo as my email address, not number.
     

Share This Page