iMovie Theater videos "unavailable" on Apple TV

Discussion in 'Apple TV and Home Theater' started by dgalvan123, Dec 12, 2013.

  1. dgalvan123 macrumors 6502a

    Joined:
    Feb 16, 2008
    #1
    Scenario:
    I just set up a new Apple TV 3 and turned on the iMovie Theater feature by inputting my iCloud information.

    Problem:
    The 4 movies I had previously uploaded to iMovie Theater (via iMovie on my mac) do appear as blank thumbnails with titles on the Apple TV, but there is no photo in the thumbnail. And when I try to play one of the videos, I get a brief "loading" screen, and then an error message: "This content is currently unavailable. Please try again later."

    iMovie theater is working fine on my iPhone 5 and on my mac in iMovie, and I have the latest firmware for Apple TV 3.

    Anyone else have this problem, or a solution?

    I've already tried:
    -restarting ATV3 (no change)
    -logging out, then back in, to iCloud on the ATV3. (no change)
    -Adding a new video to iMovie Theater from my iPhone. (a new, blank thumbnail and the correct title for the movie I added appears on the Apple TV, but still can't play it or any of the others.)
     
  2. priitv8 macrumors 68030

    Joined:
    Jan 13, 2011
    Location:
    Estonia
  3. dgalvan123, Dec 13, 2013
    Last edited: Dec 16, 2013

    dgalvan123 thread starter macrumors 6502a

    Joined:
    Feb 16, 2008
    #3
    Thanks for the response.

    Turns out that, after no action other than waiting 24 hours, iMovie Theater on my Apple TV has started working.

    It seems to take an extremely long time for the videos to load (like, more than 5 minutes to load a 30-second video), but once it's loaded it plays just fine. (note I have cable internet at ~10-12 Mbps, and the videos in my shared photo streams load normally/quickly, so not sure why iMovie Theater has this slow-loading problem.)

    *shrug*

    UPDATE: Ok, now I've actually switched ethernet cables and found a major improvement in speed of streaming for this device. I think my problem, surprisingly, may have been a bad ethernet connection, possibly via a bad cable. Did not expect that, but switching out the ethernet cable seems to have solved the problem, and others I was having with this unit.
     
  4. Fiveave macrumors newbie

    Joined:
    Oct 11, 2015
    #4
    I have same problem since El Capitan.no joy from apple tech.probable another bug
     
  5. Kriskool macrumors newbie

    Kriskool

    Joined:
    Nov 8, 2015
    Location:
    Bordeaux
    #5
    Same problem here I am in France. I just unpacked my new Apple tv fourth-generation and I see that I cant stream my imovie theater videos ! it really ******* me off !!!! And I understand by reading this post that the problem has been going on for years it's incredible !!! I can have everything YouTube Dailymotion flex, infuse.. streaming video services except Imovie theater which is an Apple service I can't believe it.

    CRAPP !!!!
     

Share This Page