Installation was a disaster, MBP “Disc Damaged”

Discussion in 'OS X Mountain Lion (10.8)' started by Mtbchris, Jul 26, 2012.

  1. Mtbchris macrumors newbie

    Joined:
    May 25, 2012
    #1
    Downloaded ML last night, and things did not go well.

    I'm now stuck in the upgrade loop, every time I start to run, I get a warning that my disc is damaged, Disc utility can scan the disc and recommends repair, but the repair options are greyed out.
    Can't restore from my time machine backup as the disc can't be found, and I can't format the HD there is a warning that the 'disc can't be ejected'.
    Safe start mode doesn't seem to work either.
    Each time I restart I go straight back to the upgrade front page.

    It's all a bit weird, I've never had a problem updating before, everything was working fine before I upgraded, thankfully I made a time machine back up right before I downloaded mountain Lion.

    I can't think of what's gone wrong, unless I have been unlucky enough to have had a disc failure at the same time as doing the upgrade.
    Disc in question is an aftermarket Momentus XT 500GB.

    Is anyone able to help before I pack up my stuff and head to the Apple store on Saturday?
     
  2. suzzzr, Jul 26, 2012
    Last edited: Jul 27, 2012

    suzzzr macrumors newbie

    Joined:
    Jul 26, 2012
    #2
    This is what worked for me

    Had exact same problem, what I did was:

    1. Went here and downloaded the recovery assistant, booted in the recuvery USB drive, holding the option key.
    2. Selected Disk Utility, Verified the disk and tried to recover it, error came up saying everything was very bad.
    3. Shut down the MacBook Pro, disconnected and connected the USB.
    4. Powered up the mac and booted into the usb once again
    5. Selected "Install OSX"(or something similar), pressed cancel 1 minute after the "Downloading additional components" started.
    6. Restarted the mac, booted in the USB again, verified the hard drive, no more errors.
    7. Restarted once again and booted into Snow Leopard without problems
    8. Used this to create a bootable USB stick, and used the USB to load mountain lion.
    9. KEPT MY MAC AWAKE, SO IT DOESN'T GO TO SLEEP DURING INSTALLATION

    This is what worked for me, hope it helps
     
  3. taiyang macrumors newbie

    Joined:
    Jul 26, 2012
    #3
    This is what I've done

    (1) Shut down MAC and switch it on again
    (2) Press command R
    (3) A window will appear, click the icon next
    (4) Choose Disk Utility
    (5) Select your main HD (the disk that it says damaged) on the left
    (6) Select Repair Permission (it might take an hour or so)
    (7) Select Repair Disk

    It works for me..
    Now I'm installing Mountain Lion again.. and hope nothing bad will happen
     
  4. green94 macrumors regular

    Joined:
    Mar 17, 2009
    #4
    Same exact thing happened to me... Going to try fixing based on posts above. Will report back.
     
  5. orvn macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #5
    Thanks for the tips guys. I'll try these too a report back.

    I have a thread detailing this issue + screenshots here
    http://forums.macrumors.com/showthread.php?t=1412338

    ----------

    Interesting you mention that. My Macbook also seemed to stop performing install functions when the display went dim (not even sleep).

    It would just apparently pause.
     
  6. CoreForce macrumors regular

    Joined:
    Aug 28, 2003
    Location:
    Zurich, Switzerland
    #6
    Same issue for me on an iMac 17" Core Duo 2

    Can not repair permissions though, that partition of the drive is greyed out.
    I can check and repair the volume but this is just saying everything is alright without any solution to the problem.
    Arranged visit with Apple Store....
     
  7. Plutarch macrumors newbie

    Joined:
    Jul 27, 2012
    #7

Share This Page