Installed beta 2, worked fine, then my harddisk is not recognized after a reboot

Discussion in 'macOS High Sierra (10.13)' started by simzen85, Jun 26, 2017.

  1. simzen85 macrumors newbie

    simzen85

    Joined:
    Jun 26, 2017
    #1
    In the Recovery mode - Disk utility, I can see the partitions but it's not mounted and I can't do anything with it. I tried to reset NVRAM etc with no luck.

    Anyone knows how to fix this ? Tks
     
  2. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #2
    I have a similar issue. I converted my external HDD to APFS and now it won't boot up.
     
  3. simzen85 thread starter macrumors newbie

    simzen85

    Joined:
    Jun 26, 2017
    #3
    I solved mine. You can use another external hard-drive with at least Sierra to boot, then manually mount the troubled partition, then use "Startup Disk" in Preferences to restart with the original partition and hopefully it will be bootable now :)
     
  4. ErikGrim, Jun 28, 2017
    Last edited: Jun 29, 2017

    ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #4
    Startup Disk didn't recognise the internal drive as bootable. Installing High Sierra beta on the external drive now and will try reinstalling the beta to the internal drive from Recovery Mode.

    Here's what happened:

    - installed beta 2
    - came back to find a not blessed error message and a restart button (not clickable due to not connecting to BT mouse/keyboard)
    - force restarted, same screen with different error
    - reboot in recovery mode
    - ran disk utility first aid, couldn't complete due to unknown error
    - ran reinstall macOS beta from recovery mode
    - came back to find the dreaded question mark folder
    - force restarted into recovery mode, got internet recovery instead (uh oh)
    - installed Yosemite on external drive, rebooted, internal drive not recognised (expected)
    - upgraded to Sierra on external drive, internal drive recognised (phew)
    - deleted the macOS install payload (well tried to, SIP stopped me from emptying trash)
    - ran the macOS beta install from Applications
    - could not select internal drive because not HFS+ formatted (WAT!)
    - upgrading external drive to High Sierra b1
    - upgrading external drive to High Sierra b2
    - Run first aid on internal drive again (that failed earlier) <- Current status
     
  5. verdi1987, Jun 29, 2017
    Last edited: Jun 29, 2017

    verdi1987 macrumors regular

    Joined:
    Jun 19, 2010
    #5
    I did a clean install of High Sierra Public Beta on my MBP. Formatted the partition as APFS Encrypted. Installation progressed, and I left while it installed. When I came home, the screen was all black with a green pointer. Hard reset the MBP, and again it just displayed a black screen with green arrow. Finally got it to display the boot menu, and HS was not recognized.

    Trying to install a second time. If the result is the same, I’ll try formatting as HFS+.

    Update: Second install succeeded.
     
  6. Sourstash macrumors newbie

    Joined:
    Jun 29, 2017
    #6
    I had to boot up into a Linux Live USB stick and delete the partition and create a random one, then I had to boot back into the macOS High Sierra usb stick I created and choose disk utility and create the APFS again and install High Sierra which took awhile to install on my HDD.
    My HDD partition got locked. It was the only partition. I've read this is happening a lot.
     

Share This Page