Installing Classic?

Discussion in 'Mac Help/Tips' started by emoin, May 24, 2003.

  1. emoin macrumors member

    Jan 2, 2003
    My iBook went crazy a couple of months ago, so I had to format the harddrive and reinstall OS X and do a Software Restore. For the first time since then I tried to run Classic, and it says that Classic can't run because "There is no volume with a system folder that supports running Classic."

    So, the question is, how would I go about remedying this? Is it part of the Software Restore CD, or the OS X CD?

  2. Freg3000 macrumors 68000


    Sep 22, 2002
    New York
    I always thought you needed OS 9m installed in order to have Classic. Of course that is wrong, since the new Macs don't have OS 9 but do have Classic. I know when I check my system prefs and click Classic, it seems like it is based off the system folder....which is in OS 9.

    So, in conclusion, I have no idea how to do it. Try software restore, I seem to remember a check box asking whether or not to install Classic. I am not sure though.
  3. Schiffi macrumors 6502a


    May 22, 2003
    You need OS9 installed to run Classic. If your iBook is new, OS9 is prolly on the restore disk as a hidden .dmg.

    1. Open up Terminal (in /Applications/Utilities) and on the command line type:

    % cd "/Volumes/Software Restore/.images"

    Replace "Software Restore" with the name of your CD as it appears on the desktop.

    2. Type ls at the command line and you should see some disk image (.dmg) files, including OS9General.dmg (again yours may be named differently than mine - I don't know).

    3. Mount the disk image from the command line with open ./OS9General.dmg.

    4. Open up the mounted disk image in the Finder. Also open up where you will be putting OS9 (anywhere is fine). Select all folders in the disk image and copy them to the location.

    5. Go to SysPrefs and click on the Classic icon. Choose your Classic sys folder, or whatever makes it recognize OS9 is there.
  4. emoin thread starter macrumors member

    Jan 2, 2003
    I tried this, and after the first step I got an error in the Terminal that said there were too many arguments in the command. I don't know if it makes any difference, but in my case, the CD was called "iBook Restore CD". Any ideas?

    EDIT: I figured it out! The files are still copying so I don't know yet if it's going to work, but thank you so much :)

Share This Page