Internet painfully slow on one mac but fine on all other devices.

Discussion in 'Mac Basics and Help' started by emilybrearey, May 22, 2015.

  1. emilybrearey macrumors newbie

    Joined:
    May 22, 2015
    #1
    Hi all.

    I am having connectivity problems on one Macbook Pro, but not another. It appears to be hogging a lot of bandwidth with something in the background because once Problem Mac is connected, all the other devices on the network slow way down. I've been on the phone with Time Warner Cable (my ISP) all morning have determined that it's not a problem with our internet connection.

    Here are my specs:

    Problem Mac
    MacBook Pro (13-inch, Mid 2010)
    Processor 2.4 GHz Intel Core 2 Duo
    Memory 4 GB 1067 MHz DDR3
    Graphics NVIDIA GeForce 320M 256 MB
    Ookla Speedtest results:
    Download - 8.97 Mbps
    Upload - 1.13 Mbps

    Happy Mac
    MacBook Pro (15-inch, Early 2011)
    Processor 2.2 GHz Intel Core i7
    Memory 4 GB 1333 MHz DDR3
    Graphics Intel HD Graphics 3000 384 MB
    Ookla Speedtest results:
    Download - 16.07 Mbps
    Upload - 1.23 Mbps

    Additionally, when the Problem Mac is connected to the network (but not doing anything to my knowledge), the Speedtest results for the Happy Mac are:
    Download - 12.41 Mbps
    Upload - 1 Mbps

    After some Googling, I found that it might be a permissions problem so I verified and repaired the permissions, but the problem persists. I also tried changing the channel on my router. I have restarted both machines several times (every time I try a new fix).

    Let me know if I've left out any pertinent information.

    Thank you!
    Emily
     
  2. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #2
    Does the issue occur with both Wi-Fi and Ethernet?
     

Share This Page