Internet stops working on 4S occasionally

Discussion in 'iPhone' started by 3bs, Nov 24, 2011.

  1. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #1
    Not sure why it happens but sometimes after leaving my apartment where I have wifi on, I notice that the Internet on my 4S isn't working. I try turning mobile data off then on and also tried turning airplane mode on then off but neither work. Turning off the phone seems to get it to work but that's too much of a hassle having to do. I tried replacing my sim card but that didn't work. What should I do? Anyone have this problem? Only solution I can think of is a restore or contacting Apple for a replacement.
     
  2. walindour macrumors member

    Joined:
    Oct 5, 2003
    Location:
    Seattle, WA
    #2
    Something like this happened to me this evening at home on my personal wifi. Internet slowed to a crawl so I shut down the phone and powered it back up. No change. Terrible speeds. So I researched with my iPad, tested speeds to make sure it wasn't a weird router issue and looked on the forums for advice.

    I picked up the phone after a few minutes and it was working fine again. Speedtest showed 6mbps up and down. Didn't test when it was crawling but it was weird. I have only had the phone a few days so this is a new issue for me. Hopefully it is the last of it. Do you have an Apple Airport router? Some folks were having issues with Apple Base Stations.
     
  3. 3bs thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #3
    I have a time capsule linked to y router to extend the network but my issue is not at home. It happened again today so I I called Apple and they made me pay 30euro for a replacement and they froze the price of my iPhone from my credit card until the get my iPhone and I get the replacement.
     

Share This Page