Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Introducing a new way to run OS 9 on supported non-G4 and G5 macs, 100% compatible!

Rikintosh

macrumors regular
Original poster
Apr 22, 2020
102
118
São Paulo, Brazil
Not all mac mini can boot mac 9, and the few that do, don't work properly.

Natively and unofficial, they mean, respectively: Macs that you can place the installation cdrom of mac os 9, and install without problems, unofficial supported macs, means that if you install the installation cdrom, it will not boot, mac was not made for mac os 9, it has more modern hardware incompatible with os9, but doing some hacks, it can start in a precarious way.
 

Rikintosh

macrumors regular
Original poster
Apr 22, 2020
102
118
São Paulo, Brazil
Not all mac mini can boot mac 9, and the few that do, don't work properly.

Natively and unofficial, they mean, respectively: Macs that you can place the installation cdrom of mac os 9, and install without problems, unofficial supported macs, means that if you install the installation cdrom, it will not boot, mac was not made for mac os 9, it has more modern hardware incompatible with os9, but doing some hacks, it can start in a precarious way.

The way to use os9 on unsupported macs (mainly for old games) is with OSX + Classic. OS9 does not have support for video cards, the sound will not work properly, you will be stuck without a browser, without internet, without wifi, without SSL, etc ... No programmer will develop a driver or application for os9, it is not interesting.
 
Last edited by a moderator:

Rikintosh

macrumors regular
Original poster
Apr 22, 2020
102
118
São Paulo, Brazil
This discussion reminds me of something ...



Poor old Ludwig was stuck with 100-year-old+ technology by the time of his professional career!

And just to add insult to injury, he was too dull and uncreative to raise money to afford eye surgery!

LOL, what an idiot! :D

Don't want to compare technology from that time with today. He was not making a rube goldberg machine to compose his music.
 

Person Man 2

macrumors newbie
Nov 4, 2015
22
35
I am interested in part of this work, but I don't want to run a "stripped down" version of Tiger. What did you do to move the version of Classic from Panther to Tiger? I wish to run Tiger 10.4.11 mostly as is but with the Panther version of Classic. I am also curious as to what files from earlier versions of Tiger you moved to 10.4.11?
 

Rikintosh

macrumors regular
Original poster
Apr 22, 2020
102
118
São Paulo, Brazil

retta283

macrumors 68020
Jun 8, 2018
2,188
1,994
Victoria, British Columbia
Anyone able to try Shadow Warrior using this? I can't get to any of my PPC machines for about two weeks, curious if it works though. One of my favorite OS 9 games. Doesn't work at all in Classic mode on Panther/Tiger, and I'm pretty sure it doesn't work on Jag's either.
 

Person Man 2

macrumors newbie
Nov 4, 2015
22
35
My guess is probably not. This is mainly a heavily skinned OS X 10.4.11 with it's Classic.app replaced with the one from Panther, with some OS X pieces removed (I'm not sure which ones) and some OS X pieces replaced with ones from earlier 10.4.x versions, per his description. If something doesn't run under Classic on 10.2, 10.3, or 10.4, it probably won't run on this, either.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.