iOS 12.1.3 ― Bug Fixes, Changes, and Improvements

Discussion in 'iOS 12' started by Banglazed, Jan 22, 2019.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. TimFL1 macrumors regular

    Joined:
    Jul 6, 2017
    Location:
    Germany
    #126
    Bold of you to say the car doesn‘t matter, because my Mercedes updates the signal strength over bluetooth just fine. And yes, my phone is in standby in my pocket.
     
  2. mikehalloran macrumors 6502a

    Joined:
    Oct 14, 2018
    Location:
    The Sillie Con Valley
    #127
    This makes little sense to me. My Xs and 2013 Toyota sync just fine ... as have my earlier Toyotas and iPhones. iOS 12.1.3 changed nothing.

    iPhone stays in my pocket. It just works. I certainly don't pay attention to the strength meter — oh, I did in 2008 when this was all new to me, I admit.
     
  3. CyberVisitor macrumors 6502

    Joined:
    Oct 25, 2017
    #128
    On the contrary, this version of iOS is very smooth on my iPhone XS Max. I’m very satisfiied indeed. This could be the best ever iOS I have experienced. Very well done Apple!
     
  4. Eksoccer99, Jan 24, 2019
    Last edited: Jan 24, 2019

    Eksoccer99 macrumors regular

    Eksoccer99

    Joined:
    Mar 19, 2018
    #129
    Battery level indicator seems broke/stuck. Doesn’t move/showing that the battery level is going down per the percentage all day for me. Currently 87% with what appears to look like a full battery. Idk. Maybe some adjustments were made.
     
  5. arforbes, Jan 24, 2019
    Last edited: Jan 25, 2019

    arforbes macrumors newbie

    Joined:
    Jul 16, 2018
    #130
    I'm hoping someone can provide me with some insight on how to fix this issue. When 3D force touching a message to quick reply I keep getting a bug popping up saying "iMessage needs to be enabled to send this message. "

    Does anyone know a fix? Thanks in advance!!


    EDIT: Removing and reinserting the physical SIM fixed the issue (even though I had the physical SIM line turned off)
     
  6. aj.dahlenburg macrumors newbie

    Joined:
    Aug 14, 2015
    #131
    Gonna sift through this list and reinstall and report back guys, thanks for the feedback. Settings still hangs for a quick second especially If you don’t use it for a couple hours and instinct to instinctuall if you don’t use it for a couple hours and Instinctually switch back to settings from multitasking. Still kind of annoying but you have to have all the stock apps for the Settings app to function how to present all mornin instinctually switch back to settings from multitasking. Still kind of annoying but you have to have all the stock apps in place in order for the Settings app to work 100% speed!

     
  7. Blue Hawk macrumors regular

    Joined:
    Dec 18, 2017
    Location:
    Germany
    #132
    I have full cellular signal but it's not possible to make phone calls. I get the message that I have to enable WiFi calling to make a call
     
  8. acmfaxxe macrumors member

    Joined:
    Dec 25, 2017
    #133
    Hello,

    I am not sure but I believe that since the update to iOS 12.1.3 my iPhone X in the lock screen no longer recognizes when I read something. Normally, the iPhone X (s) will indeed notice when looking at the screen and will not turn off the screen. If I unlock the iPhone, swipeup, it still works. Only when I read messages etc. on the lock screen does it turn off the display after a short while. Was that already with iOS 12 versions before the case or only since the update to 12.1.3?
     
  9. tbaer macrumors member

    Joined:
    Mar 11, 2012
    #134
    Not having the same issue but in my case I answered a WiFi based call and then a few seconds in the call dropped with “call error” message. The phone probably tried to hand over to cellular (1 bar for what it’s worth ) although I had great WiFi signal.
    My X did not have those issues. XS has all kinds of cell radio issues for me in the same environment.
     
  10. Jayson A macrumors 68000

    Joined:
    Sep 16, 2014
    #135
    Hi all, I updated from 12.1 to 12.1.3 on my iPhone 7 Plus and I'm not seeing any issues in regards to cell data or connectivity.

    Just thought I'd mention in case someone else has been holding off due to the horror stories.
     
  11. solodogg macrumors 6502

    Joined:
    Oct 28, 2011
    Location:
    Orlando
    #136
    Bold of you to claim it works without proof that the screen wasn't turned on while in your pocket. I'll be more than happy to post videos of multiple cars with it not working if you'll post a video of just your car with it working.
     
  12. Rhonindk macrumors 68040

    Rhonindk

    #137
    Stock email with 4 GMail accounts linked and one Exchange account. Running into two issues:
    1. Inbox in Unread mode reverts to All emails after a couple of hours. This applies to all accounts and All Inbox
    2. On the Gmail accounts the initial badge will show 2x the actual number of unread emails. Once the screen is refreshed it corrects itself.

    iPhone 8+
     
  13. TimFL1 macrumors regular

    Joined:
    Jul 6, 2017
    Location:
    Germany
    #138
    I also had it sitting in a cupholder approximately 395 times over the last several months (pocket is just an example), the signal most definitely updates. Sorry it doesn't work for you, it absolutely does for me in my car (and the rental car I had for 2 days). MacRumors exaggeration at it's finest, classic.
     
  14. solodogg macrumors 6502

    Joined:
    Oct 28, 2011
    Location:
    Orlando
    #139
    Many people on here have noted the lack of signal strength updating in both CarPlay and Bluetooth connections, so it must be that you're the only person that got a phone with a different bluetooth chipset in it. The only time it will work is if you receive a notification and the display on your phone turns on for more than a couple of seconds, and this has been confirmed on MANY car systems (which is irrelevant anyway).

    FACT: Signal strength WILL NOT update on ANY in-car system while the phone is not in use (display off) because the phone itself doesn't update its signal while the display is off. It has ZERO to do with the system being used in your car, and everything to do with the phone software not allowing the signal update to run in the background while the display is off. Like I said before, PROVE ME WRONG. Someone touting a 256GB Xs, 44mm Apple Watch, 15" MBP, and a Mercedes surely has another camera lying around and 30 seconds worth of time to video his phone with the display off and the signal still updating on the car display. I would love to be able to upload evidence of it working on someone's phone to the Apple bug reporter.
     
  15. Martyimac, Jan 25, 2019
    Last edited: Jan 25, 2019

    Martyimac macrumors 68000

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #140
    Me also, I like to check the car display to see if I am driving by a Verizon tower or somebody elses. Easy to tell, yes Solodogg, even with the phone "off" in my belt sheath.
     
  16. solodogg, Jan 25, 2019
    Last edited: Jan 25, 2019

    solodogg macrumors 6502

    Joined:
    Oct 28, 2011
    Location:
    Orlando
    #141
    Once again, prove it. Drive 1 mile with the screen off and make a video of the signal on your car display updating while the phone screen is off. I’ll wait...

    Only time mine has worked on the Xs was when using CarPlay with Google Maps navigation, and I forgot to turn the display off before putting the phone in the center console. Outside of that, never updates. As said before I’ve tested on Sync 2/3, MyLink, and UConnect 8.4” systems all with the same results, and with both Xs and Xs Max.

    @timmywa still having the same issue with your phone as well?


    --- Post Merged, Jan 25, 2019 ---
    Yep, tested this again today and you’re correct. But I did also test while using Google Maps, forgot to turn the screen off on my phone prior to throwing it in the center console, and signal updated the entire time. So it’s definitely based on the display being powered up and the phone not in standby mode.
     
  17. Martyimac macrumors 68000

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #142
    No, I know it works. Really don't have to prove anything to you, especially since I haven't seen your proof. And even if you post it, I don't care.
     
  18. solodogg macrumors 6502

    Joined:
    Oct 28, 2011
    Location:
    Orlando
    #143
    Wow...thanks for the response and for contributing to correcting bugs, much appreciated.
     
  19. Martyimac macrumors 68000

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #144
    So, just for you, a faceless entity whom I don't know. How do you explain that my car will connect to my iphone, showing signal strength etal, when the screen isn't active? Yes I just tried it and the screen never came on but the bluetooth is active even with the screen off. No, there were NO apps active when I did this experiment.
    It isn't a bug so there isn't anything to correct. Oh, you're welcome.
     
  20. solodogg macrumors 6502

    Joined:
    Oct 28, 2011
    Location:
    Orlando
    #145
    Reading comprehension isn’t a strong suit of yours is it?

    Nobody has argued about whether or not Bluetooth itself works when the screen is off on your phone, or whether signal is displayed when the screen is off, but the signal does not update while driving around.

    Once again, plugged my phone into the Jeep tonight, turned on CarPlay and made a phone call while the display was showing 4 bars of signal, and drove all the way home still displaying 4 bars. It wasn’t until I pulled in the garage and turned the display back on that it updated to show the normal 2 bars I typically see when sitting in the garage at the house. There are many places in my trip home that drop down to a single bar, and many places that normally show full signal, but the radio constantly remained at full signal regardless of these locations even when the phone was on an active call.

    Tomorrow, I’ll drive the Mustang and repeat the exact same thing again. If my battery is charged, I’ll grab a video showing the phone connected and signal not updating at all over a 20 minute drive thru 3 different cities. If you would take a few minutes to read the details and do some searching around jere, you would see that it IS a known bug, I have reported it to Apple already, and it’s still a work in progress.
     
  21. radubraharu, Jan 26, 2019
    Last edited: Jan 26, 2019

    radubraharu macrumors regular

    radubraharu

    Joined:
    Jan 20, 2018
    Location:
    Romania
    #146
    I have the xs and the same behavior. Beside this, sometimes when I unlock my phone I need to enter the passcode (this has never happened before). Ram management is also worse, apps like WhatsApp need to reload every 10 minutes. All this happened until yesterday. In the afternoon I force closed all apps, cleared ram cache and restarted the phone. Since then everything works fine except the animations. Sometimes they still lag visibly.
    Is it possible to downgrade to a previous version without losing data? I know that it was possible to downgrade from 12 to 11, or 11 to 10 without losing data, and I would be happy to do so from 12.1.3 to 12.1.2

    Edit: I managed to downgrade without losing data, and I’ve installed the tvOS 12 beta profile so I don’t get prompted for other updates. Maybe I will check 12.2 out after it’s released to see if it will be good for my phone.
     
  22. TimFL1 macrumors regular

    Joined:
    Jul 6, 2017
    Location:
    Germany
    #147
    Just drove to grab breakfast and had my iPhone XS 256Gb (iOS 12.1.3) connected to bluetooth with no screen on (sitting in my cup holder) and no apps or music active: I could see the signal bars go from 4 to 2 and 1 and back, assuming I jumped between 4G and E because coverage is bad on the route I took.

    I‘d record it just to prove that guy wrong, but I don‘t really have to prove a bug doesn‘t exist (it‘s the other way around I‘d wager?) and I don‘t know how to anyway, because my phone is the only device with a camera I have. So I guess you‘ll have to take my word for it, reiterating again: what do I gain from lying to you on the internet? You obviously seem to have issues with the signal strength updating, I hope you report it with proof in the feedback app. There are lots of strange iOS issues that are either not reproducible or simply only happen (or don‘t happen) on a selected few devices. Like I never had that weird awards disappearing bug, or the notifications coming in all broken looking. But I guess I‘m lying about that also?
    This is certainly my last post about this „issue“ because I have better things to do than fight over a „bug“ on a MacRumors forum.
     
  23. jtkboston macrumors member

    Joined:
    Oct 23, 2014
    #148
    iPhone XS, VZW eSIM and ATT-based MVNO physical SIM. VZW primary. physical SIM turned off yesterday as I am traveling in USA to an area with no coverage on that service.

    Installed 12.1.3 when it came out to the public a few days ago.

    Last night, I plugged phone in when going to sleep, it was at 98% but this is habit.
    Picked up this morning, completely dead.
    Didn’t respond to hard-reset sequence at first, but after about 5 tries over 15 minutes it eventually reset and restarted, looks to be normal again, and battery is fully charged.

    Coincidence? or bug in 12.1.3?
     
  24. radubraharu macrumors regular

    radubraharu

    Joined:
    Jan 20, 2018
    Location:
    Romania
    #149
    After the update my phone got dead also. But only for around 30 seconds. It didn’t respond to anything, but when it got responsive again, it continued from the lock screen,, with the apps open on the ram, it didn’t reboot.
     
  25. Blue Hawk macrumors regular

    Joined:
    Dec 18, 2017
    Location:
    Germany
    #150
    Is that a bug? Restored my iPad with iTunes. It downloaded and installed the latest iOS version. It’s in German. But when I want to delete an app the description is english.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page