iPhone iOS 13 - Signal Bars still do not update in CarPlay or Bluetooth

iammike1

macrumors 6502a
Original poster
Oct 25, 2007
735
12
O'fallon IL
How has this not been addressed? This has been messed up for quite some time for those with Intel modems.

Basically, the signal bars in CarPlay or through a Bluetooth connection will stay at whatever signal the phone had when it was connected. It will not update.

The type of connection WILL update though, like LTE, 5Ge, Wifi. Just not the signal bars.

Mine is on an iPhone XS on AT&T but from looking around before, it seems to impact phones with Intel modems.

Every great once in awhile it will actually work right but it's pretty rare. Haven't seen my signal update on screen in months now.

I know it's a small thing but it's been going on long enough it's really starting to annoy me.
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,520
8,773
Ventura County
Had a rental car last week with CarPlay, running iOS 13 GM, did not have this problem at all. Have you reset network settings or reset all settings?
 

iammike1

macrumors 6502a
Original poster
Oct 25, 2007
735
12
O'fallon IL
Had a rental car last week with CarPlay, running iOS 13 GM, did not have this problem at all. Have you reset network settings or reset all settings?
I have but I'm trying it again. I've done a full restore on this phone before too with no luck. With as many people out there share the problem, it's something more than a fluke.
 

iammike1

macrumors 6502a
Original poster
Oct 25, 2007
735
12
O'fallon IL
So, today got a new 11 Pro, brought it home, did a full reinstall of the OS and setup the phone as new. Signal Bars still stuck. grrrr
 

iammike1

macrumors 6502a
Original poster
Oct 25, 2007
735
12
O'fallon IL
Maybe it’s an issue with your car?
It could be but that means it's a not uncommon problem with peoples cars since, at least according to searches on Reddit, I'm far from alone.

It's also strange that the problem only started exactly when I got my XS which was my first iPhone with an Intel modem and best people online seem to be able to tell, this problem only impacts people with Intel modems...but not all people with Intel modems.
 

iammike1

macrumors 6502a
Original poster
Oct 25, 2007
735
12
O'fallon IL
On more thought, it can't be a problem on the car side. While the signal bar is stuck, if you activate the screen on the iPhone (no need to unlock, just tap it) then the signal bars will update until the screen goes dark again.