iOS 5.0 GM for iPhone 4 (GSM model) lacking "personal hotspot" / tethering feature?

Discussion in 'iPhone' started by RamGuy, Oct 5, 2011.

  1. RamGuy macrumors 6502a

    RamGuy

    Joined:
    Jun 7, 2011
    Location:
    Norway
    #1
    I just updated to the GM build of iOS 5.0 for my iPhone 4 32GB (GSM model) and was hoping this might resolve all the different issues I've experienced with the personal hotspot / tethering feature with iOS5.0.

    But it seems like Apple have removed the whole "personal hotspot" feature from the settings panel? Has it been re-located to somewhere else or have Apple actually removed the whole feature?
     
  2. macingman macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #2
    Have you got a tethering plan? I think they may have moved the tethering options in general-network not sure though.
     
  3. Caris macrumors 6502a

    Caris

    Joined:
    Sep 25, 2006
    Location:
    Newcastle Upon Tyne, UK
  4. MagnusF macrumors regular

    Joined:
    Jul 12, 2010
    #4
    Do you have wifi on?

    Go to settings - general - network - personal hotspot and turn on personal hotspot
     
  5. jauhari macrumors regular

    jauhari

    Joined:
    Mar 20, 2007
    #5
    There is no personal hotspot menu on this area...
     
  6. MagnusF macrumors regular

    Joined:
    Jul 12, 2010
    #6
    It is there for me.
     
  7. RamGuy thread starter macrumors 6502a

    RamGuy

    Joined:
    Jun 7, 2011
    Location:
    Norway
    #7
    I'm using Telenor in Norway, so I shouldn't need to have any tethering plan from my provider.


    WiFi on or off doesn't make any difference.
    There is nothing named personal hotspot anywhere, neither under settings - general - network.
     
  8. philstone macrumors 6502

    philstone

    Joined:
    Oct 13, 2008
    Location:
    Jersey, Channel Isles
    #8
    Are you using an official carrier? Apple have screwed up for non official carriers and you can't set the APN settings yourself. If you have no Internet Tethering APN details you won't be able to see the Personal Hotspot.
     
  9. merc73 macrumors member

    merc73

    Joined:
    Sep 10, 2008
    #9
    Just reset network settings, it will appear. It works for me.
     
  10. Lunchb0x8 macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Aberglasslyn, NSW, AU
    #10
    This fixed it for me!
     
  11. jauhari macrumors regular

    jauhari

    Joined:
    Mar 20, 2007
    #11
    Reset Network Setting and then go to
    Settings > General > Network and enable Personal Hotspot...
     
  12. philstone macrumors 6502

    philstone

    Joined:
    Oct 13, 2008
    Location:
    Jersey, Channel Isles
    #12
    Are you guys all on official carriers?

    Just done a full restore to GM on my iP4 and even after numerous reset network I'm still getting no Personal Hotspot or the ability to edit the mobile data network APN settings (I am not on official carrier - there aren't any in Jersey, UK)
     
  13. Canuckk macrumors newbie

    Joined:
    Jun 29, 2008
    #13
    I was having the same issue, actually, and resetting my network settings did nothing to help. What did fix it, though, was modifying a .plist file (this requires being jailbroken if I'm not mistaken).

    For those of you that are jailbroken, here is what you do: navigate to /var/mobile/Library/Preferences and open the file entitled com.apple.MobileInternetSharing.plist. There should be 2 values there, one is called "State" and should have an integer value associated with it (mine was 1024). You want to then change this integer to 1022, and respring or restart your phone. You should then have Personal Hotspot enabled again.

    Not the most convenient fix, but it works.
     
  14. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #14
    I also had this issue yesterday, but it seems to be fine today.

    I didn't try resetting anything.

    (I'm on O2 UK - an officially supported carrier)
     
  15. ssdeg7 macrumors 6502a

    ssdeg7

    Joined:
    Jul 15, 2010
  16. PLamarine macrumors 6502

    PLamarine

    Joined:
    Jun 12, 2009
    Location:
    Central MA
    #16
    +1
     
  17. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #17
    Resetting network settings likely won't add it to the main settings menu. What you have to do after the reset is go into General -> Network and enable it there. It will then appear on the main menu.
     
  18. whitehill76 macrumors member

    Joined:
    Jun 19, 2010
    Location:
    Glasgow
    #18
    O2 in UK

    i phoned o2 about this, they will get back to me in '3 or 4 days'!

    Anyways, go to General, Reset, Network Settings.

    If that doesnt work, if you then go into the Network Settings options screen personal hotspot will now show up, switch it on there and then its all restored
     
  19. superflush macrumors 6502a

    Joined:
    Apr 6, 2009
    #19
    Did you get this working on Telenor?
    Some carriers have it turned off unless you have a plan. With other carriers you just need to enter in the right APN settings.
    Just curious if Telenor allows tethering without an additional plan.
     

Share This Page