Lyons00

macrumors 6502a
Original poster
Dec 9, 2010
571
49
Bay Area, California
Hi,

I know this is a beta and it worked with beta 6. But, is anybody else having problems, when plugging in my iPhone 4, iTunes does not open up automatically. I'm on Windows 7 64 bit. The, open iTunes when the phone is connected is grayed out. Once I open iTunes manually my phone does show on the left hand side. Is there a way to fix this, or wait until the GM comes out?

Thanks, Jerry
 
Last edited:

Lyons00

macrumors 6502a
Original poster
Dec 9, 2010
571
49
Bay Area, California
Hi,

I know this is a beta and it worked with beta 6. But, is anybody else having problems, when plugging in my iPhone 4, iTunes does not open up automatically. I'm on Windows 7 64 bit. The, open iTunes when the phone is connected is grayed out. Once I open iTunes manually my phone does show on the left hand side. Is there a way to fix this, or wait until the GM comes out?

Thanks, Jerry

Anyone please?

I just uninstalled iTunes and reinstalled it and it's still not opening when I plug my iPhone 4 in.

Thanks, Jerry
 

andybno1

Suspended
Nov 6, 2007
3,642
38
Liverpool, UK
could be iTuneshelper.exe isn't launching when your computer boots, this exe file detects the device being plugged in and will launch itunes accordingly.

if you have the itunes setup exe file right click and extract the contents and do a repair install of AppleApplicationSupport, AppleMobileDeviceSupport and Bonjour and see if that helps.

If this doesn't work, uninstall everything apple from control panel:
Apple Application Support
Apple Mobile Device Support
Apple Software Update
Bonjour
iTunes
Quicktime

then just run iTunes setup again and hopefully should fix your problem
 

Lyons00

macrumors 6502a
Original poster
Dec 9, 2010
571
49
Bay Area, California
could be iTuneshelper.exe isn't launching when your computer boots, this exe file detects the device being plugged in and will launch itunes accordingly.

if you have the itunes setup exe file right click and extract the contents and do a repair install of AppleApplicationSupport, AppleMobileDeviceSupport and Bonjour and see if that helps.

If this doesn't work, uninstall everything apple from control panel:
Apple Application Support
Apple Mobile Device Support
Apple Software Update
Bonjour
iTunes
Quicktime

then just run iTunes setup again and hopefully should fix your problem

Hi,

Just tried both of your solutions and neither one of them worked. Does not open when I plug my phone in, but when I open iTunes manually, it shows up on the left hand side. Not sure why it won't open, other then maybe, it's still in beta. Beta 6 worked fine and beta 7 won't open.

Thanks again, Jerry
 

andybno1

Suspended
Nov 6, 2007
3,642
38
Liverpool, UK
hmm well beta 7 is working fine here, what I posted was best solution, maybe try the uninstall again and then restart computer then reinstall?
 

Lyons00

macrumors 6502a
Original poster
Dec 9, 2010
571
49
Bay Area, California
hmm well beta 7 is working fine here, what I posted was best solution, maybe try the uninstall again and then restart computer then reinstall?

Hi,

Tried what you said and still doesn't open. I'm lost now, I've tried everything. Guess I'll wait until we get GM.

Thanks, Jerry
 

jacollins

macrumors 6502a
Jun 19, 2010
531
0
Did you try a different USB port? I find iTunes (Windows version) to be beta enough as it is (without trying out the beta's)... :) However, it's "lost" the iPhone before on the port it's on, and switching ports seems to fix it for me.
 

Lyons00

macrumors 6502a
Original poster
Dec 9, 2010
571
49
Bay Area, California
Did you try a different USB port? I find iTunes (Windows version) to be beta enough as it is (without trying out the beta's)... :) However, it's "lost" the iPhone before on the port it's on, and switching ports seems to fix it for me.

Hi,

I've tried every USB port on my PC and it still won't open. Thanks for trying to help out.

Jerry
 

onetimehelper

macrumors newbie
Jul 5, 2012
1
0
Figured it out

Ok. So I had the same problem.

Luck would have it that I happened upon the solution.

My "open itunes when the phone is connected" was greyed out and so I opened itunes.

From the menu bar >>> Edit >>> Preferences

From the Devices Preferences Go the to "Devices" tab.

There is a checkbox called "Prevent Ipods, Iphones, and Ipads from syncing automatically".
Unclick that box.

Now the "open itunes when the phone is connected" should now be clickable.

PS: Hope this was it. I signed up just to help you after all. ;)

~~onetimehelper
 

Spectrum Abuser

macrumors 65816
Aug 27, 2011
1,377
48
Ok. So I had the same problem.

Luck would have it that I happened upon the solution.

My "open itunes when the phone is connected" was greyed out and so I opened itunes.

From the menu bar >>> Edit >>> Preferences

From the Devices Preferences Go the to "Devices" tab.

There is a checkbox called "Prevent Ipods, Iphones, and Ipads from syncing automatically".
Unclick that box.

Now the "open itunes when the phone is connected" should now be clickable.

PS: Hope this was it. I signed up just to help you after all. ;)

~~onetimehelper

I would hope that he got the help he needed a long time ago. :rolleyes:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.