iPhone iOS 9.1 + iPhone 6: The Photos app keeps crashing whenever I try to open it.

Discussion in 'iOS 9' started by live.cn, Nov 16, 2015.

  1. live.cn macrumors newbie

    live.cn

    Joined:
    Oct 16, 2015
    #1
    The Photos app (the system default app) crashes every time I try to open it. Some investigations:

    1. The Photos app defaults to open the Album view, this is where it crashes.
    2. If I open Camera, and taps the bottom left icon to bring up Photos, it will default to Calendar view, which doesn't crash.
    3. If I switch from Calendar view to Album view, it crashes again.
    4. When I compose an Email and select "Insert Photos", it crashes too.
    5. I tried deleting the Photos.sqlite files using iExplorer, and reboot the phone to let it rebuild the library. At the end of rebuilding process, it started to crash again.
    6. I've connected the phone to XCode and obtained the crash log. I've attached it in the post. Here is the interesting bits. I can't find anything useful on Google.

    Code:
    Incident Identifier: 63EEB9FB-8179-44B2-A625-9A782BC35938
    CrashReporter Key:   8593ee223d64940ebdf59937eb68fd3f1b04c6ad
    Hardware Model:      iPhone8,1
    Process:             MobileSlideShow [18420]
    Path:                /Applications/MobileSlideShow.app/MobileSlideShow
    Identifier:          com.apple.mobileslideshow
    Version:             43 (1.0.0)
    Code Type:           ARM-64 (Native)
    Parent Process:      launchd [1]
    
    Date/Time:           2015-11-15 23:48:28.28 +0800
    Launch Time:         2015-11-15 23:48:25.25 +0800
    OS Version:          iOS 9.1 (13B143)
    Report Version:      105
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Subtype: KERN_INVALID_ADDRESS at 0x000000010fa1c000
    Triggered by Thread:  19
    
    ...
    
    Thread 19 name:  Dispatch queue: com.apple.root.user-initiated-qos
    Thread 19 Crashed:
    0   vImage                           0x0000000181f67550 vConvert_420Yp8_CbCr8ToARGB8888_vec + 784
    1   ???                               0x00000000000003e0 0 + 992
    2   vImage                           0x0000000181f32a98 Do_vImageConvert_420Yp8_CbCr8ToARGB8888 + 164
    3   libdispatch.dylib                 0x00000001993b1c2c _dispatch_client_callout2 + 16
    4   libdispatch.dylib                 0x00000001993c2ebc _dispatch_apply_invoke + 96
    5   libdispatch.dylib                 0x00000001993b16a8 _dispatch_client_callout + 16
    6   libdispatch.dylib                 0x00000001993bfb40 _dispatch_root_queue_drain + 2140
    7   libdispatch.dylib                 0x00000001993bf2dc _dispatch_worker_thread3 + 112
    8   libsystem_pthread.dylib           0x00000001995c5470 _pthread_wqthread + 1092
    9   libsystem_pthread.dylib           0x00000001995c5020 start_wqthread + 4
    
    
    
    Anyone has the same issue? This is quite frustrating. T_T
     

    Attached Files:

  2. Makale.Helvetia macrumors 6502a

    Makale.Helvetia

    Joined:
    Sep 14, 2014
    Location:
    İSTANBUL - TÜRKİYE
    #2
    turn off icloud photo library and icloud photo sharing options from icloud section and try again, i've issued the same thing several moths ago,and fixed by that way
     
  3. live.cn thread starter macrumors newbie

    live.cn

    Joined:
    Oct 16, 2015
    #3
    Thanks for your reply. I tried both. Still crashes for me... T_T
     
  4. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #4
    I wonder if you have a corrupted image in there somewhere.

    When did the crash start happening? Maybe offload all photos you've taken since then, and delete them from your library?

    If you open your photo library from your Mac or on the web do you see any corrupted looking photos?
     
  5. live.cn thread starter macrumors newbie

    live.cn

    Joined:
    Oct 16, 2015
    #5
    Thanks for the tips. Guess I have to manually go through all recent photos. Actually many of them are saved from web so I'm not sure if i've been hit by some kind of buffer-overflow trojans....
     

Share This Page