iOS bad text „speak“ quality

Discussion in 'iOS 11' started by bmot, Apr 5, 2018.

  1. bmot macrumors regular

    Joined:
    Feb 25, 2016
    #1
    When selecting text in iOS, for example in safari and then selecting “speak” to have the text being read, the quality of the speaker is noticeably inferior to Siri’s voice and rather sounds like a Windows text reader from the 90’s.
    Why is that, why can’t it be consistent with the good quality Siri voice?
     
  2. friednoodles Suspended

    Joined:
    Feb 4, 2014
    #2
    It can be. Go to:

    Settings - General - Accessibility - Speech - Voices - select the language you need to change, then choose the persona/voice you want to use for it (make sure you're selecting the correct region/dialect as there are often several for a given language). Siri, including enhanced versions, should be available in there if your region/dialect supports it.
     
  3. bmot thread starter macrumors regular

    Joined:
    Feb 25, 2016
    #3
    Sadly that’s not working. No matter what voice I download and select in this section. When having text read in safari, the same robotic voice is being used.
     
  4. friednoodles Suspended

    Joined:
    Feb 4, 2014
    #4
    There are a multitude of subtle things that could cause this, including the website in question, but for starters make sure Settings - General - Language & Region - Preferred Language Order is correct. The Voices section (and other parts of iOS) will use this order when selecting what voice to use for text to speech, so if it doesn’t contain an exact match (and with a higher priority) for the region/dialect you’ve selected a voice for in Voices, it will use the default.

    E.g. if you have selected a voice for English (UK), you also need English (UK) above other English entries in Preferred Language Order for it to use it. Also be sure when selecting a Voice that it has a check mark next to it - in most cases where there are multiple options for a single voice (like Daniel and Daniel Enhanced), you have to tap into the sub menu first and select the desired option in there. Tapping it on the main list won’t put a check mark next to it.
     
  5. bmot, Apr 7, 2018
    Last edited: Apr 7, 2018

    bmot thread starter macrumors regular

    Joined:
    Feb 25, 2016
    #5
    In speech settings for english “Siri female (United States)” is selected.
    In language and region > iPhone language “English (U.S.)” is selected and the first in order.

    Actual voice when using speech in safari is the “Windows 95” robotic voice.

    This:
    Confirms what a cluster **** this system has developed into in the last years.

    I also googled the issue. Someone was reporting the same issue on the official Apple forum. Apples answer was to restart or if that doesn’t work reinstall iOS from scratch.
    Seriously, we have officially reached Windows standards at this point.
     

Share This Page