iPad Pro iPad Pro 2018 12.9” has green icon but won’t charge (and not discharges)

Discussion in 'iPad' started by qap, Aug 2, 2019.

  1. qap macrumors 6502

    qap

    Joined:
    Mar 29, 2011
    Location:
    Italy
    #1
    Hello, my new iPad Pro 2018 12,9” won’t charge after yesterday morning. I tried every USB C cable and charger, also hard reset via hold button up-down and power and also via restored via DFU.

    It recognizes the charged, the icon became green but the percentage don’t change.

    I have a Genius appointment, but if someone can help, it’s very frustrating. The iPad Pro is almost new and I’ve never damaged it, I also always used 10w charges old iPads charger to avoid battery damage (with the heat).. and now all my sacrifices became useless

    Thanks
     
  2. ericwn macrumors 68030

    Joined:
    Apr 24, 2016
    #2
    It sounds as if you already tried all the troubleshooting steps and that all was unsuccessful. I think the forum will likely not be able to help and that Apple needs to have a look. Best success for your appointment!
     
  3. willmtaylor macrumors G4

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    Here(-ish)
    #3
    Are you using it while trying to charge or is it sitting unused?
     
  4. qap thread starter macrumors 6502

    qap

    Joined:
    Mar 29, 2011
    Location:
    Italy
    #4
    Both, but now it’s charging (without usage) since 10 hours ago but it’s still stuck at 71%
     
  5. ericwn macrumors 68030

    Joined:
    Apr 24, 2016
    #5
    Have you tried the charger that came with the device?
     
  6. AutomaticApple macrumors 68000

    AutomaticApple

    Joined:
    Nov 28, 2018
    Location:
    Massachusetts
    #6
    I wish you luck with your appointment!
     
  7. willmtaylor macrumors G4

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    Here(-ish)
    #7
    My suggestion, quit trying to fix the problem before the appointment. As hard as it is, if you have the scheduled appointment, let the problem be until then.
     
  8. qap thread starter macrumors 6502

    qap

    Joined:
    Mar 29, 2011
    Location:
    Italy
    #8
    Back from the Apple Store... the results are, well, inconclusive after all the diagnostic tests they were unable to understand/find the issue (I mean the damaged hardware or what else...) but they also found/detected the iPad was not charging also with the Apple store chargers/cables.

    So they agreed in a replacement unit but they also were withou any other iPad Pro 12,9 cellular in the warehouse....:mad: so I have to wait 4/5 days with an iPad that I can’t charge... like a slow and atrocious death :D
     
  9. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #9
    Does the current charge (whatever it might be) maintain at that level if you use your iPad while the charger is plugged in?
     
  10. qap thread starter macrumors 6502

    qap

    Joined:
    Mar 29, 2011
    Location:
    Italy
    #10
    Yes, it’s the only small consolation. But sometimes the charge level also changes, for example after a reboot or an hard reset it shows 5/6% more... to me seems like the iPad is having some troubles to communicates with iOS or the “SMC” like in the Macs, tu the Apple store guy was unable to run the diagnostic test for the power, if the energy goes inside the iPad, and if not, why. Because the iPad with USB-C is too new and they don’t have the hardware for the USB-C iPads :mad:
     
  11. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #11
    So, Apple is going to get you a replacement, but you should be able to use your non-charging iPad for whatever you do, as long as you don't go far from a mains socket. :cool:
     
  12. qap thread starter macrumors 6502

    qap

    Joined:
    Mar 29, 2011
    Location:
    Italy
    #12
    9B712EFF-1E40-4DC0-942C-D20B885DF7AF.jpeg Yes, something is definitely missed between iOS and the iPad battery, if I disable the percentage, every reboot reappears but the toggle is still disabled :confused:
     

Share This Page

11 August 2, 2019