iphone 1g - 2.2.1 - home button, mic and dock connector not working (blown by surge?)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by manjha, Nov 10, 2009.

  1. manjha macrumors newbie

    Joined:
    Nov 10, 2009
    #1
    My iphone 1 g running f/w 2.2.1 was connected to the pc and charging when the pc SMPS (power supply) went dead probably due to some voltage surge. I got the power supply replaced and the pc is working fine again, but the iphone won't charge and finally wend dead.

    I opened the iphone and desoldered the battery, charged it at 12v for 30 minutes and soldered it back. The iphone jumped back to life and booted up fine. But I realized that the home button and mic are also not working. Fortunately I have SBSettings installed with Kill Process plugin enabled. So I have to kill apps using it.

    But there is no workaround for the mic and the dock connector. How do I source and replace them. I have figured out that I need the "flex ribbon cable for the home button and dock with embedded mic". Is that the only way?

    Any suggestions? Has anybody done this before? Any pointers to detailed instructions?

    Thanks in advance .. all help counts.
     
  2. Gadgetgeezer macrumors regular

    Joined:
    Oct 4, 2009
    #2
    I have changed the dock, ribbon, mic, speaker, home button etc. It's a very difficult job and only attempt it if confident else find a local repairer. If you have been inside the phone, are you sure you haven't dislodged the ribbon from the connector under the board?
     
  3. manjha thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #3
    I only went to the extent of removing the battery. The flex ribbon cable is still stuck with tape as originally, so there should be no chance of dislodging its connector.

    Moreover, the dock connector wasn't atleast charging. So I guess, something's gone bad there only. Do you any photos or other references I could use as hints to do the repairs?

    Thanks,
     

Share This Page