iPhone 2G fails to connect via USB, stuck at Apple logo screen with spinning wheel

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Richard0612, Oct 13, 2009.

  1. Richard0612 macrumors newbie

    Joined:
    Oct 13, 2009
    #1
    Here's an interesting one, any advice would be much appreciated.

    To cut a long story short, I purchased a dud iPhone from ebay, thinking it would be an easy fix. The seller said that it stopped working when he tried to upgrade the phone's software to 3.1. I've repaired various iPods and other gadgetry before, so I thought that this would be simple. Wrong!

    Here's a list of the symptoms:
    1. iPhone doesn't boot properly, gets to Apple logo screen, waits for a couple of minutes, then the spinning wheel appears for another five or so before the thing reboots
    2. No communication over USB. iPhone is not recognised by a computer whatsoever. I've tried two PCs and a Mac to no avail.
    3. Recovery mode or DFU mode have no impact at all on connectivity. I could be screwing up the DFU mode process, but I've tried several times.

    And here's a list of anything else that might be relevant:
    • iPhone appears to charge, both over USB and mains, although without booting the OS, I can't be sure.
    • I've tried two USB sync cables, no dice.
    • I've tried connecting to three computers, one running Windows 7, one XP, and the other OS X 10.5.6 (yes, I know about the DFU issue, I patched it)
    • No application can recognise the iPhone. iRecovery, iLiberty, etc, etc. I've even used USBDevViewer to check, doesn't show up at all. All the ports are USB 2.0 and known good at high-speed, 5v. EDIT: I've also tried hooking it up to a Linux box and running the lsusb command. Nothing. This machine only has USB 1.1 ports, so it's not a (weird) 2.0 issue.

    Differential diagnosis, people! :p
    Seriously, I'm running out of ideas and patience, any help would be very much appreciated. I'm beginning to think that the logic board could be fried (or the USB controller at the least), although how a software update could cause that, I don't know (then again, everybody lies...)

    Thanks for reading.
     
  2. vinhmen macrumors newbie

    Joined:
    Jul 10, 2007
    #2
    If DFU mode doesn't work you're pretty much screwed.
     
  3. Richard0612 thread starter macrumors newbie

    Joined:
    Oct 13, 2009
    #3
    My thoughts had been going that way...
    Logic board dead/malfunctioning, I assume...
     

Share This Page