iPhone 3g weird screen colours

Discussion in 'iPhone' started by Marcus-k, Apr 12, 2012.

  1. Marcus-k macrumors regular

    Joined:
    Nov 17, 2011
    #1
    I'm not entierely sure if this is the correct place for posting this, but anyways:

    Hi, i've recently opened my iPhone 3g for cleaning it from dust, and doing this i removed only the screen assembly and disconnected the screen / touchscreen and one other cable. After doing this the screen is showing weird colours, almost like a negative.

    I was very careful when dissasembling it and putting it together, but it think that something happend to the screen, cable from the screen or where it is attached to the logicboard. I've tried to remove the cable and reattaching it several times, but still get the same weird result. Everything works fine except for the colours on the screen.

    Here are some pictures of how it looks:

    http://imageshack.us/photo/my-images/638/imag0815p.jpg/
    http://imageshack.us/photo/my-images/14/imag0818j.jpg/
    http://imageshack.us/photo/my-images/402/imag0823u.jpg/
    http://imageshack.us/photo/my-images/685/imag0832.jpg/

    Does anyone know what went wrong? Or how i can figure out what happend? I', pretty sure the ribbon cable from the screen is correctly attached, and i see no damage on that or the place it connects to on the logicboard.
     
  2. Marcus-k thread starter macrumors regular

    Joined:
    Nov 17, 2011
    #2
    Now i also noticed that the colours seem normal in the app "Safari", and the preview screen of "Images".

    I've tried to do a couple of factoryresets and they seem to have made no difference.
     

Share This Page