iPhone 3G WiFi "Unable to Join the network (SSID of netowrk)"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dannystro527, Feb 3, 2011.

  1. dannystro527 macrumors newbie

    Joined:
    Feb 3, 2011
    #1
    For the past few days now, I have not been able to connect to any wireless connections. Not my home connection, work, school, public, other friends wireless networks, nothing. I know this has been a big problem, but mine is pretty high scale.

    I have tried every type of reset possible. I've done a regular reboot, hard reset (holding home and sleep button), power cycle (holding sleep button while sliding to turn off), reset all network settings, reset all data on phone, still nothing worked. Tried the typical work arounds, e.g. turn on and off airplane mode, turn on bluetooth reset then turn bluetooth off and turn on wifi.

    I'm getting no IP, no subnet, no router, all fields are blank. I know about networking, I'm majoring in college for it, so i know it isn't my network. I've tried manually configuring the IP and all, and it didn't work either.

    I've even tried restoring. I was on 3.1.3 when the problem happened. So, i updated to 4.2.1, didn't work. Restored to 4.1, nothing. Did a DFU restore to 3.1.3 AND 4.2.1, both having no success. I've even tried the stupid freezer trick. I'm out of ideas. I got the phone from my sister who cancelled her contract with AT&T, and i have it on a gophone plan right now, and used WiFi for data, and now that's screwed up. She bought applecare, never registered it, and has no receipt showing when she payed, so i can't even try to register it.

    Any help would be appreciated, please?! Sorry for the huge first post ever, but that's how much I've done to try to fix this :/
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    Since you have done everything possible to find a software fix, my money would on a hardware issue. I know it's out of warranty, but maybe you could get a Genius to at least check it out for you.
     
  3. grawk macrumors 6502

    grawk

    Joined:
    Jan 26, 2004
    Location:
    Southern York County, PA
    #3
    I've had good luck going to apple for weird problems, even out of warranty. Even if they don't replace it under warranty, they may sell you a refurb replacement cheap without a contract.
     
  4. ahlborn39 macrumors newbie

    Joined:
    Feb 24, 2011
    #4
    iPhone 3G
    Same issues after ios v4.2.1
    went though all what you did and I was able to get the mac address to show up and get the router to ask for a PW but will not connect.
    I pulled out the simms card a few times and then reset the network settings.
    I updated my wife 3G to v 4.2.1 and it has been find so far.
    I called Apple support and Apple is aware of this issue. no hotfix so far.
    DA :mad:
     
  5. JamesMB, Feb 24, 2011
    Last edited: Feb 24, 2011

    JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #5
    Try removing the security from the router, and see if it will connect. If that works, change to a different type of security.
     
  6. ahlborn39 macrumors newbie

    Joined:
    Feb 24, 2011
    #6
    No difference.
    I changed the security from the router and change to a different type of security. :mad:
    DA
     
  7. ahlborn39 macrumors newbie

    Joined:
    Feb 24, 2011
    #7
    Oh yah I forgot you can select the network key in the PW and a window pops up can not join and then it loops over and over.
     
  8. this is funah macrumors 6502

    this is funah

    Joined:
    Oct 13, 2005
    Location:
    Berlin, Germany
    #8
    i know this sounds a little crazy, but try plugging in headphones or taking them out when connecting.

    this works for me every time. (with iPhone 4)
     

Share This Page