iPhone 3gs updated to 4.3.3 BB 6.15 won't get out of DFU

Discussion in 'iPhone' started by upkomsai, Aug 23, 2011.

  1. upkomsai macrumors newbie

    Joined:
    Aug 23, 2011
    #1
    need your expert advice guys.

    i have placed my iphone into DFU mode. i had an error 1600 when i tried restoring the first time, but i fixed that with iReb. now, i have successfully restored from itunes my iphone 3gs 4.0.2 to 4.3.3 using Shift + restore and selecting the 4.3.3 FW. so i go on with redsnow_win_0.9.6rc16 and install cydia and the ipad baseband. redsnow says done, and i see the phone in verbose, then the pineapple logo and the horizontal bar slowly filling up. and then, phone won't come on - still in DFU mode (black screen). it won't turn on no matter what i do. it won't get out of DFU mode.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Did you put your iphone in "pwned" dfu mode with redsnow before you try to load the custom 4.3.3 on itunes?
     
  3. upkomsai, Aug 23, 2011
    Last edited: Aug 23, 2011

    upkomsai thread starter macrumors newbie

    Joined:
    Aug 23, 2011
    #3
    yes, i put the phone in "pwned" dfu with iReb and also did it weith redsnow.


    and one more thing, redsn0w asked me if my iphone is a newer (fixed) model. i did both yes and no. i did that because after restoring from itunes, i can't turn my phone back on to check the serial number. by choosing yes, redsnow suddenly quits while fetching the baseband. i did it several times. by choosing no, redsnow reports it is done with what it needs to do and all the other process starts on my device
     
  4. upkomsai thread starter macrumors newbie

    Joined:
    Aug 23, 2011
    #4
    just an update, i restored it one more time with 4.3.3 using the same process as above. now, when asked if my iphone is a fixed model, i choose no and redsn0w crashes in the "fetching baseband" part. when i choose yes, redsn0w proceeds and says "done". verbose text on the phone, then comes the pineapple logo. half-way through the bar (flashing baseband), phone turns off. back to pwned DFU.
     
  5. upkomsai thread starter macrumors newbie

    Joined:
    Aug 23, 2011
  6. upkomsai thread starter macrumors newbie

    Joined:
    Aug 23, 2011
    #6
    for anyone who gets into this problem, here's a fix i tried and worked for me:

    click here
     

Share This Page