iPhone 3gs wifi problem

Discussion in 'iPhone' started by edovann, Oct 19, 2012.

  1. edovann macrumors newbie

    Joined:
    Oct 19, 2012
    #1
    I never had problems with my wifi connectivity
    until i updated it to iOS 5.1.1 and now, when i move away from my router a bit (going out of the room) and it loses the signal!!!

    Never happend with other iOS..

    reseted the router and "forgot" the network , and it worked great for 5 minutes and then went back wrong.
    tried to reset network settings --> didnt help

    ( My sister's 4s works just fine with 5.1.1)

    This is very annoying i must say!

    How can i resolve it??
     
  2. fruitpunch.ben macrumors 6502a

    fruitpunch.ben

    Joined:
    Sep 16, 2008
    Location:
    Surrey, BC
    #2
    I'm not going to solve your problem but the same thing happened to my 3GS. I don't know for sure it was after I installed 5.1.1 but it was about 6 months ago (when was 5.1.1 released?). The wifi signal would be extremely weak, and would not work unless I was within 10m of the router.
    BUT it got worse and worse. Later, it would not be able to log onto wifi networks at all. And now, my 3GS does not even see any wifi networks, and if I type my network name/password in manually, it cannot find the network.
    This was not fixed by setting up the iPhone from a new phone, or upgrading to iOS 6.

    I had assumed that it was just a loose hardware connection because the phone has been dropped a fair bit, but it's interesting that you have a similar problem. Maybe it is software!
     
  3. edovann thread starter macrumors newbie

    Joined:
    Oct 19, 2012
    #3
    Well, i would have thought it could be fixed with iOS 6 but, i see it is not fixed as you say..i just don't know what to do .. i hope someone can come with a solution.
     

Share This Page