iPhone 4 and Airport Extreme - not compatible??

Discussion in 'iPhone' started by Sean Dempsey, Feb 5, 2011.

  1. Sean Dempsey macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #1
    I just bought an AEBS (Airport Extreme Base Station).

    I set up a 5ghz network, and then a regular b/g/n network. My mac pro and macbook pro connect to the 5ghz N network fine. My internet speed is around 25 Mbit.

    Since the iPhone doesn't do 5ghz, it connects to the b/g/n antenna, which is fine. Only when I run the speedtest app off the iphone... it gets less than 1 Mbit.

    I've googled around, and it appears that the iphone 4 doesn't do well with the AEBS, is this true? It's pretty disappointing to go get this supposedly awesome router, only to have the iphone completely fail on it.

    Someone has had to run into this before. Is the AEBS and iphone 4 combination just a dud?
     
  2. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
  3. Sean Dempsey thread starter macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #3
    Neither my 4 or 3GS can get download speeds over 1Mbit.

    Plus, the iPhone 4 doesn't even have a 5ghz antenna, so you're mistaken.

    This is ridiculous, everything connects to an AEBS except iPhones?


    I've set up the dual band radios to be:
    802.11 N only (5 GHz) - 802.11 b/g/n

    And have the N network on a different SSID. But when the iphones are connected to the b/g/n network, they can't even get 1 Mbit.
     
  4. stisdal macrumors 6502

    stisdal

    Joined:
    Feb 28, 2010
    Location:
    USA
    #4
    I have an AEBS set up with dual bands and consistently get 7+ Mbps on 2 iPhone 4's and an iPhone 3GS. My iPad connects through the 5ghz band and gets 16+.

    Try different channels on your g band. (I just set mine on automatic but you may have interference nearby) Also make sure you are using WPA/WPA2 Personal for security. I also use multicast set at medium, and use wide channels.

    I have had absolutely zero issues with Apple and PC connectivity and speed since setting up my AEBS this way.

    Hope this helps.
     
  5. bwrairen macrumors 6502

    Joined:
    Jun 23, 2010
    #5
    Just tested mine. 16.26mbps. running in N mode (B/G compatible).
     
  6. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #6
    Just tested mine and it works very well - 15.34 down and 1.91 up with 64ms ping time. And my AEBS is at the opposite end of the house (about 55-60 feet away) from where I tested.

    I would say try resetting both your AEBS and restarting your IP4. If it still is slow, try resetting network settings on the IP4. If that still doesn't work, try restoring the IP4 as new (not from backup) for a clean start.

    If none of that works, maybe you have defective hardware - most likely the IP4 because you get good speeds with the AEBS using other devices. At that point, I would take it back to an Apple store and exchange it out.
     
  7. synagence macrumors 6502a

    Joined:
    Jul 23, 2008
    #7
    I get 8 down and 0.5 up on my iP4 connected to the 'g' network of my AEBS
     
  8. Sean Dempsey thread starter macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #8
    Well, this AEBS is screwed up then.

    With a 25 megabit down / 3 megabit up internet connection, even standing 5 feet away from the router, I get less than 1 megabit download, but the same 3 megabit up as my computers do.

    I've sat and messed with the antenna settings and channels, but neither the iphone 4 or 3GS can get any sort of appreciable download speed when connected to this router.

    It doesn't make any sense, even over a 54megabit G network, a 25mbit download speed to translate to more than 1mbit over an iphone wifi, especially considering that the Cisco E2000 router I replaced did just fine with the iphones.
     
  9. iFitz macrumors regular

    Joined:
    Jul 15, 2008
  10. jamesds04 macrumors newbie

    Joined:
    Mar 22, 2011
    #10
    AEBS & iPhone Compatibility

    I recently purchased a new MacBook Pro (03/18/11) and decided to upgrade my router to the new AEBS. Setup was easy and my MBP performs beyond my expectations on my network. Now for the bad part..... My iPhone 4 crawls or wont work at all on the new network. It' actually 2-3x faster to turn off the wireless on the phone and surf using 3g. My girlfriends iPhone 3gs has the same results. I've went through all the normal resets of the phone, router, modem, etc. I even went so far as to restore my iPhone and nothing has helped. I see this problem in many blogs and have contacted Apple via their website. If anyone has suggestions or a fix, please let me know. Thanks All.

    **Update**

    On a hunch I turned off the airport on my MBP and my phone works great on the AEBS network. I then reconnected my MBP and both are now working great. Any one else having these compatibility issues please try this:
    Disconnect all devises from your AEBS. Reset your AEBS. Connect your iPhone first and see if the network speed is what it should be. Then connect other devices and note their speed.
    The only thing I can think of is that you need to lock on to the 2.5Ghz signal first for the phone or there is interference/confusion between the 2.5 & 5. Hopefully the next iPhone will be wireless n compatible.
     
  11. Stein357 macrumors 6502

    Joined:
    Jun 18, 2010
    Location:
    Rip City
  12. S1njin macrumors 6502a

    S1njin

    Joined:
    May 3, 2010
    Location:
    NJ
    #12
    Try updating the firmware on your AEBS.
     
  13. frunkis54 macrumors 65816

    frunkis54

    Joined:
    Apr 2, 2009
    #13
    I have a Time capsule which isn't that much diferent than the AE and I just remember pluging it in giving it a SSID and password and everything connected no problem macbook,iphone,ipad.
     
  14. seble macrumors 6502a

    Joined:
    Sep 6, 2010
    #14
    Their like a match made in heaven for me. Post a pic of all your settings, so we can compare?
     
  15. jwingfie macrumors 6502a

    jwingfie

    Joined:
    Dec 30, 2008
    Location:
    Athens, GA
    #15
    18.9 down and 1.1 up on my iP4 connected to my Airport Extreme here.
     
  16. jeffdrafttech macrumors newbie

    Joined:
    Aug 22, 2011
    #16
    I know this is an old thread, but it is selected by google when I search my problem.

    My Airport Extreme always worked great, then I upgraded it.

    Now it won't work with my 4S or my iPod touch. It will connect, but extremely slowly and almost unusable.

    I tried downgrading the AEBS firmware but the problem persists.

    If I turn on the wifi on my ATT UVerse modem, it connects great.

    Apple TV and two macs still connect to the Apple wireless router fine.

    This AEBS firmware upgrade also broke the connection to my printer and my Sony internet alarm clock.

    ???

    Called Apple Care for my phone and they want me to had reset my iPhone and restore it from backup. Because I backup to iCloud, this would take hours because it would need to re-download my apps. The referred me to Apple care for my Airport Extreme but they want to charge for support because I don't have Applecare for it.

    F it. I'm just connecting to my ATT router.

    Airport is not a great product. I have Airport Extreme and Airport Express for Airplay, and I can't connect an Apple phone.
     

Share This Page