iphone 4 and public wifi

Discussion in 'iPhone' started by sparkiesteve, Feb 18, 2012.

  1. sparkiesteve macrumors newbie

    Joined:
    Feb 18, 2012
    #1
    My iphone 4 is unlocked, it is running ios4. I live in an apartment block which has wifi. i am subscribed to this wifi on my macbook pro and it works fine. my iphone 4 sees the network and lets me 'connect' but then it doesnt bring up the screen even when i open safari to enter my user name and password so i can log on to my account. therefore i cannot use the internet through wifi. it says im not connected. i have tried resetting network settings and forgetting the network etc. it did work once many moons ago but now its is fecked. please help my before my phone gets launched through the 10th story window. cheers :D
     
  2. motoleo macrumors 6502a

    motoleo

    Joined:
    Jan 27, 2012
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    If the connection you're trying to get on requires you to enter credentials- a screen should pop up at shortly after you try to enter an address.

    I will admit, I don't know what initiates the pop up screen. So I try to be careful. I turn Wi-Fi off, then back on- I wait. If the popup screen doesn't come up, I check the weather app. It should, bring up the login screen before it says "updating..." at the bottom.

    If that doesn't work, finally I try to enter an address, but the login screen has to show up at some point.

    So I usually just wait.
     
  3. cynics macrumors G3

    Joined:
    Jan 8, 2012
  4. sparkiesteve thread starter macrumors newbie

    Joined:
    Feb 18, 2012
    #4
    thanks for the quick replies. yeah tried both of those. for some reason i never get the screen that asks for my details no matter what i do. i tried opening safari and lots of other apps that use the net but i never get the sign in screen so i can log on to my account. tried the reset as well.
     
  5. nwmtnbiker macrumors 68000

    nwmtnbiker

    Joined:
    Apr 5, 2011
    Location:
    Fidalgo Island
    #5
    Reset Network Settings under Settings/General/Reset might do the trick.
     

Share This Page