iPhone iPhone 4, attempting to restore 5.1.1, have tried stiched IPSW, error -1, help.

Discussion in 'Jailbreaks and iOS Hacks' started by gwynne, Oct 12, 2012.

  1. gwynne macrumors 68000

    gwynne

    Joined:
    Mar 11, 2010
    #1
    Ok, I'm admittedly rusty at this, but I read enough recent forum threads to try to educate myself before asking for help.

    I have a previously JB'd iPhone 4 (ATT) on 5.1.1. I wanted to restore it and re-JB for selling. After reading a bit, I determined the need to make a 'stitched' IPSW. Redsnow was able to verify the device's blobs on Cydia, and successfully used them to stitch a 5.1.1 ipsw. (To be explicit: Cydia does have 5.1.1 and 5.1.1r blobs, per its home screen on the device.)

    I then applied it using shift-restore in iTunes (Windows).

    At the end, error -1.

    I see multiple posts saying "if error -1, use Redsnow or TU to get it out of recovery mode".

    TinyUmbrella: right-click allows me to exit Recovery, but the iphone just then eventually goes back to the recovery screen.

    RedSnow: I select "Recovery Fix". It then takes me to the DFU instructions, starting with "Hold down the power button until the slide to power off" thing. But in this mode, the power-slide never appears, the screen (the USB -> iTunes recovery icon) just turns off. If I try to power it back up after that and follow the DFU instructions as normal, RedSnow tells me I've done it wrong.

    (I know DFU can be a pain but I've successfully done it many times, including earlier today to get RedSnow to do the blob retrieval/stitch.)

    Am I still missing something obvious?

    Thanks.
     
  2. pltvu macrumors newbie

    Joined:
    Aug 17, 2010
    #2
    iphone 4: After error -1, close itunes, put phone in DFU, use Redsn0w "recover fix", wait for less than 5 min for process, phone came back with 5.1.1 loaded!!!! Worked for me.
     
  3. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #3
    It's a BB problem, make a NO_BB IPSW with redsn0w and stitch the SHSH to that, than restore in pwned-DFU
     

Share This Page