iPhone 4 camera lag and multi-tasking issues

Sunsean

macrumors 6502
Original poster
Mar 27, 2012
255
0
Ok so I am on my first iPhone after a few years on Android, and overall loving it. Its a regular 4. A couple issues are driving me nuts though, maybe you guys can help me out: 1. The camera app takes forever to open and be ready to shoot a pic. I'm talking like 15-20 seconds. One of the best things about the iPhone camera is very little shutter lag, but having to wait 20 seconds before taking a pic kind of defeats the purpose. 2. Multi-tasking and background apps freezing. It seems like if I don't go back into an app within 4 or 5 minutes, when I finally DO go back into that app, it hangs for a long time before either starting to work or, more often than not, just closing and sending me back to the springboard. Doesn't this kind of defeat the purpose of multi-tasking? It literally happens with every app in the multi-tasking bar if it sits untouched for more than a few minutes.

If you guys can offer me some pointers it would be much appreciated! FYI I am jb but only have a few basic tweaks installed. Do you think these 2 issues are related to the jb? Or are these common issues on iPhones?
 

ThatsMeRight

macrumors 68020
Sep 12, 2009
2,257
124
I have never heard of the camera hanging for twenty (!) seconds on an iPhone - not even on older generation iPhones.

So either your device is defect or it's your jailbreak. I suspect it's the jailbreak. Why don't you go plain, without a jailbreak and upgrade to iOS 5.1?
 

Bugeyeblue

macrumors 6502a
Mar 27, 2011
514
9
Are you using any cracked repos or cracked apps? Those are known for causing problems. If not, I would just suggest the usual fixes, restore as new, re jailbreak if you want.
 

sers

macrumors 6502
Jan 11, 2006
273
395
I second the "go stock" route. I jailbroke my iPhone once and noticed a difference in performance. I'm sure there are some jailbreaks that don't affect performance, but it might be worth trying to use stock 5.1.1 and see if it improves things. My camera app takes about 1 - 2 seconds to open.
 

iceterminal

macrumors 68000
May 25, 2008
1,870
27
Dallas Tx.
I had this happen to me as well. I think back when I had iOS 5.0, but could be mistaken.
I found out after doing a restore, the same results happened. Albeit slightly different.
After this, I did a restore as new and the camera lag lessened to about 3-4 seconds.
I was not jailbroken at any time.

So my suggestion is to close all apps in the multi switcher tay. Test.
If still same results, perform a restore.
 

Sunsean

macrumors 6502
Original poster
Mar 27, 2012
255
0
Thanks for the feedback guys. I was afraid/skeptical that it was related to jb. I unfortunately had to jb to edit mms apn for my Straight Talk service, but as long as I did it I added a few extra tweaks. I'm on tethered 5.1, I guess I will upgrade to stock 5.1.1 and see how it goes. I have a suspicion it might be Spite, the Siri port, that's the culprit. I will probably have to jb again for my mms settings, but will only do that and not mess with the other stuff. I think I've only used Spite twice since I installed it, anyway haha, won't miss it much.

You guys have reassured me that the camera lag is unusual, but what about the multi tasking issues? Do you guys have that happen, where you will open an app that you haven't used in, say 20 minutes, and it just freezes/closes?
 
Last edited:

sers

macrumors 6502
Jan 11, 2006
273
395
I haven't experienced the multitasking issues you're having. Nothing freezes for me.
 

Sunsean

macrumors 6502
Original poster
Mar 27, 2012
255
0
I haven't experienced the multitasking issues you're having. Nothing freezes for me.
Ok thanks again for your feedback, sounds like I am just having issues due to jailbreaking. I may just skip the jailbreak thing altogether after updating to 5.1.1. Like i said, main reason I jb in the first place was for Tether Me to be able to edit mms apn settings, and I don't mms a ton anyway, it's just nice to have it when you want it. But I can send pics to other iPhone users through iMessage, and I guess I will just resort to emailing pics for everyone else. I'd rather have a fully functioning phone than put up with all these issues just so I can send an mms to an Android or blackberry once/week lol.
 

Sunsean

macrumors 6502
Original poster
Mar 27, 2012
255
0
You can jailbreak to edit your APN, then backup in iTunes, install stock iOS, and restore from backup to keep your MMS. That's what I did when I moved to Straight Talk.
This sounds like exactly what I would like to do, thank you! I have read though that it's not good to restore a jb backup...but I'm guessing if you did it, then it works okay?
 

theLimit

macrumors 6502a
Jan 30, 2007
928
1
up tha holler, acrost tha crick
This sounds like exactly what I would like to do, thank you! I have read though that it's not good to restore a jb backup...but I'm guessing if you did it, then it works okay?
The only thing I did with the jailbreak was install tetherme to enable the Cellular Data Network tab so I could edit the APN. I did the backup and restore to stock iOS and have been running perfectly fine since February with working 3G and MMS. I would definitely recommend it if MMS is your only reason for the jailbreak. I recently did the OTA update to 5.1.1 and everything is still working as expected.
 

Sunsean

macrumors 6502
Original poster
Mar 27, 2012
255
0
The only thing I did with the jailbreak was install tetherme to enable the Cellular Data Network tab so I could edit the APN. I did the backup and restore to stock iOS and have been running perfectly fine since February with working 3G and MMS. I would definitely recommend it if MMS is your only reason for the jailbreak. I recently did the OTA update to 5.1.1 and everything is still working as expected.
Thank you again for the confirmation. Tetherme/MMS really was the only reason I jailbroke in the first place, so I will definitely try this after updating to 5.1.1.
 

lordofthereef

macrumors G5
Nov 29, 2011
12,902
3,475
Boston, MA
I noticed you mentioned having installed Spire. IME siri tweaks in general were screwy, even on my 4S (obviously didn;t have Spire, but I did have other tweaks). I hadn't seen issues quite as bad as you are speaking of with the 4 (my fiance's phone), but she did experience enough lag that she decided to just go without the jailbreak all together. I think I will jailbreak her device again and see if things are any "cleaner".
 

Sunsean

macrumors 6502
Original poster
Mar 27, 2012
255
0
Yeah, it was the 5.1 version ("Spite"), but same thing. I actually got it working really smoothly, and I don't think it was the cause of the problem, here's an update: Just got back home from being on the road for a bit, and I started removing all cydia tweaks except for Spite and TetherMe, and then played with the phone a bit. Problem seemed to have been solved! One of the other tweaks must have been the culprit, because the camera was now opening in about 2 seconds, and the phone overall felt snappier than before removing the tweaks. Just updated to stock 5.1.1, and everything seems to be working great. Thanks for the help and input!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.