iPhone 4 goes to 'No Sevice' or 'Searching' Randomly

Discussion in 'iPhone' started by Sir Ruben, Nov 11, 2011.

  1. Sir Ruben macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #1
    Strange problem has started happening with one of our iPhones, its a launch iPhone 4 which has always worked flawlessly. However it has recently started going to 'Searching' or 'No Service' and can only reconnect by rebooting the phone at which point it reconnects with 4-5 bars.

    When it does this switching airplane mode on and then off brings the bars back but without the network operators name and at that point it still cant make or receive calls etc.

    I have read up about it on the web and it seems to have happened to loads of people however as of yet Im not aware of any concrete resolution.

    Things I have tried so far:

    * Reset network settings
    * Gotten a replacement sim
    * Turned of 3G

    Im planning on restoring the phone next however I have read of people saying that didnt work for them either.

    Im beginning to think it may be a hardware problem, but if anyone knows how to fix it its probably in these forums!

    If it is a hardware issue the phone is out of warranty so what would Apples charges be to help me with this? Im in the UK by the way and my network operator is Orange.

    Help!
     
  2. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #2
    Well not one single reply. Oddly enough a search of the interwebz found that a lot of people get this problem.

    So I set out to fix it myself, and I did. I came to the conculsion that somehow the software/firmware that runs the phones cellular modem had become corrupt. Either that or the antenna had become faulty. Resetting network setting etc does not resolve. Neither does tweaking the carrier settings. Here is the only way I was able to resolve it:

    1) Downloaded a fresh copy of IOS 5.0.1 to my PC.
    2) Connected the iPhone to iTunes
    3) Put the phone into DFU mode which prompts iTunes to tell you it needs to be restored
    3) shift key and restore button in iTunes prompts you to specify the file location
    4) Browsed to my freshly downloaded IOS file
    5) Phone restored perfectly and is now fixed

    If that hadnt worked there is literally nothing else to try and it would have gone back to Apple for repair. I also dont believe restoring the phone in the usual way (through iTunes or on the phone itself) would resolve the problem.

    By putting the phone into DFU more you are absolutely restoring everything. Any other method does not restore the phone in the same way.

    Good luck and let me know if it works to you too!
     

Share This Page