iPhone 4 iPod stops playing randomly

Discussion in 'iPhone' started by protobiont, Jul 9, 2010.

  1. protobiont macrumors 6502a

    Joined:
    Jul 6, 2010
    #1
    So today I was using the apple supplied headphones and listening to a podcast on my new iPhone 32 GB. Several times the audio just stopped. The first time I just restarted it, then made sure to hit the lock button before I stuck the phone back in my pocket.

    Well the problem recurred several times. When I would look at my phone I would notice that the iPod player wasn't in pause mode, it had just stopped. (the icon still showed the pause button- like it does if it's playing, but the timer wasn't moving) If then hit pause and then play it would start up again.

    Wondering if anyone else has experienced this, or has any ideas about what could be causing it.

    I haven't had a chance to extensively test any other pairs of headphones yet.

    Thanks!
     
  2. Set845 macrumors regular

    Joined:
    Jun 29, 2010
    #2
    I have experienced it just as you say. I also noticed when viewing pics in the photo app and swiping through photos, when I come upon a video the iPod stops playing even if I don't play the vid. I didn't notice if it indicated pause or play. I'll have to check that out.

    Edit: I just checked and it does indicate that the iPod is paused when I come across videos in the photo app. Not a bug there although I would have rather the OS wait for me to actually play the video before pausing the iPod.
     
  3. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #3
    I had this same problem with my first gen iPhone, what file formate is your music encoded in? aac, mp3 etc...

    for me, when my music was originally encoded in MP3, I had the same issue and the genius employee thought my iPhone was defective, so he swapped it out for a new iPhone (this was a month after the first iPhone was released, so he swapped it for a new one, not refurb) and it had the same problem.

    so after pondering what the issue could be, I realized that music I had bout from the iTunes Store didn't have this problem, only music I had encoded from my cd collection. So I re-encoded a few albums in AAC formate and that stopped the issue, so I ended up (over night) just letting my computer re-encode my entire library.
     
  4. Set845 macrumors regular

    Joined:
    Jun 29, 2010
    #4
    I've only notice it happening with Apple Lossles. I was wondering if it was a bug with that.
     
  5. protobiont thread starter macrumors 6502a

    Joined:
    Jul 6, 2010
    #5
    The file I had the problem with was a podcast downloaded from iTunes. I'm not sure what format its in.

    I haven't had the problem since - and have listened to a variety of stuff - who knows.
     
  6. UCF-ENG macrumors regular

    Joined:
    Jun 7, 2010
    #6
    I have had the same problem with both Wunder Radio and TuneIn Radio when playing in the back ground...
     
  7. quantumparticle macrumors newbie

    Joined:
    Jun 25, 2011
    #7
    @protobiont I'm having the exact same issue as you. This is about the only post on the internet I've found which explains the same thing.

    Were you able to find the cause of the issue? I've been restoring my phone to no avail, I even went and had Apple exchange my device... the problems persis on the new device after Jailbroken. I'm not sure which application may be causing the problem.

    My iPod audio on my iPhone 4 has been stopping randomly and/or skipping like a scratched CD for the past several weeks. Randomly with no way to replicate the error.

    I had this issue before updating to 4.3.3, so I don't think it's firmware or jailbreak specific... I believe one of the jailbroke apps may be causing the problem.

    Maybe we can begin to compare the jailbroken apps we have and narrow it down?
     
  8. Wheezie macrumors member

    Joined:
    Jun 17, 2010
    #8
    YES! I'm not the only one. It was fine in the previous version of the iOS. I am at the latest.

    The songs I have trouble with have been downloaded from itunes, some on the phone and some on my computer. They all play fine on the computer. It happens if my phone is NOT jailbroken and if it is. It's always random and not the same songs.

    I can stop everything in the *background* even though it's not true multi tasking, reboot the phone and still have the issue.

    It's on my iPhone 4. My wife has not reported it on her 3Gs but I listen to it at work a lot and she listens only randomly. FWIW I am not using the stock ear buds but ones that have a play/pause button on it. It happens no matter if I start the music on the phone or with the button. In fact, I could never touch the button and it would happen.

    Go Figure.
     
  9. CocoB macrumors newbie

    Joined:
    Jun 25, 2011
    #9
    I have been having this exact same problem with my iphone 4, it seemed to happen after the last update. It would stop playing randomly (but look like it was playing) or start skipping. It seems to only happen to me when I start my music, after about 5 minutes the problem goes away. I have restored a few times and set up a new phone, I have yet to try restoring with no jailbreak. I did notice that it only seemed to happen when I was using the play button on my klipsch S4i earbuds. I tested this quite a bit and I was sure it was the earbuds. I contacted klipsch and they are sending me new ones so I will see if it helps. From what I am reading here though it seems it will not fix my problem. If you want, I can post a list of jailbreak apps so we can compare and maybe solve the problem.
     
  10. orange55 macrumors newbie

    Joined:
    Jul 1, 2011
    #10
    I have the same issue, very annoying.

    I have the iPhone 4 running 4.3.3, with all my music in apple Lossless format, created from my own CD's on a windows machine. When listening to the iPod the music just stops.

    The play icon still shows in date bar at the top. Pressing play on the headphones starts it again, but often it will stop a couple of times straight away, within a second.

    After this when I press play from the headphones, it will start from the next track, not the original place it stopped.

    From what I recall it has been an issue since 4.3.0 was released and never been fixed in each of the releases.
     
  11. mtnDewFTW macrumors 6502a

    Joined:
    Oct 26, 2009
    Location:
    San Francisco, CA
    #11
    I've never encountered this problem, but it sounds like a software issue. I'd try restoring it
     
  12. GP_1 macrumors regular

    Joined:
    Mar 6, 2011
    #12
    Wow looks like I'm not the only one! My job allows me to listen to my music on my iPhone 4. When I have used the Apple Headphones it has stopped playing randomly a couple times and I've always wondered why.. Although I got some Beats by Dre studios a week or two ago and haven't had a problem.

    & my phone is NOT jailbroken.
     
  13. newyearbabie macrumors newbie

    Joined:
    Apr 18, 2009
    #13
    music & audiobooks just stop playing

    I have turned the phone off, then back on again, synched too, and I cannot resolve this problem. I get about 1-4 minutes of play, then whatever is playing just stops. I go to the song or audiobook and hit the play button, and it starts again. 1-4 minutes later it quits again. Can't find any information on how to resolve this problem, other than doing what I've already done. :(
     
  14. peteson macrumors newbie

    Joined:
    Oct 14, 2011
    Location:
    Melbourne Australia
    #14
    I have a theory

    I get the same problem but I have noticed some times the play button does go away but every time it happens regardless, there has been a internet 3G / wifi disconnection of some kind. like its trying to shut every thing down to coupe with the connection problem. The first time it happened to me I was using navigation in my car and the music stopped when I lost 3G signal.( GPS contiued to work as far as I was aware, although the program can work for a 30 seconds or so without any signal ) And also it happens the most inside the City loop in melbourne which between stations doesnt have signal. but it doesn't happen all the time though. Having said all of that I still don't know what app is causing it.

    ios 5 iphone 4
     
  15. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #15
    I am having this same problem, anybody figure out what the problem was?

    It seems to have started occurring after I updated to IOS5
     
  16. michaelsaxon macrumors 6502

    Joined:
    Nov 15, 2006
    #16
    My iPhone is also now doing this. It just stops playing but still acts as if it is. It is driving me crazy. I'm going to restore tonight. I've recently upgraded to the newest iTunes and enabled iTunes match.
     
  17. Macaddict16 macrumors 6502

    Joined:
    Oct 7, 2002
    #17
    I'm having the same problem in my iPhone 4S. The only way I can fix it is a reboot of the phone.
     
  18. indianapapi macrumors newbie

    Joined:
    Nov 30, 2011
    #18
    I have the problem. I updated to the iOS 5.01 recently but by reading this forum it seems the problems been around since iOS 4.

    All the other functions on the phone work. However yesterday iTunes tells me that I need to restore my phone from a back up or set it back up as a new phone. As if it didn't recognize the phone anymore. Good thing I didn't make many changes to it since my last backup. But after the backup is when all of the new songs I bought from iTunes stopped playing. All the stuff I bought before a few weeks ago play just fine. They even play fine in my car radio.
     
  19. indianapapi macrumors newbie

    Joined:
    Nov 30, 2011
    #19
    I fixed it by erasing all the music off my iPhone 4 (running iOS 5.01) and putting it back on. This of course took two sync's but now all my music plays like it should.
     
  20. smonteiro macrumors newbie

    Joined:
    Dec 27, 2011
    #20
    I had the same problem, but a few days ago it came back :mad:
    I had more problems though, even recording video's stopped randomly!
    initially to fix it I did a restore from backup which solved it for quite a few weeks
    I will try a restore again later today to see if it helps
     
  21. true3man macrumors newbie

    Joined:
    Jan 9, 2012
    #21
    I'm having this problem with my iPhone 4S. I play a podcast and it plays for a second then stops, I repeat pressing play every time it stops until it starts playing like a scratched CD for a few seconds before finally playing as normal. It doesn't happen to often but is very annoying. I'm having a similar issue when using Siri with headphones and wondering if they are related.
     
  22. Wrathwitch macrumors 65816

    Joined:
    Dec 4, 2009
    #22
    Glad to know I am not the only one. I put a post in here before Christmas but got no replies.

    Working out, playing my music and Bam just stops, library had not cycled through yet.

    My phone isn't jailbroken either. This all started happening after I upgraded to iOS5.

    WW

    ----------

    I am thinking of doing this too, as some songs I had (not from itunes) just don't play at all... I wonder if they messed up the way that the iP4 reads different music formats? I wonder if it has anything to do with Apple wanting people to convert all of their music over with iTunes match?

    WW
     
  23. d4m1r macrumors regular

    d4m1r

    Joined:
    Oct 1, 2011
    Location:
    Canada
    #23
    I just upgraded to iOS 5.0.1 yesterday and now I am seeing this as well...Songs just randomly stop playing, pause, etc.

    The worst is trying to skip tracks on the lock screen, sometimes they play after a 30 second delay, other times the pause icon is shown (meaning music should be playing) but no music is going....

    I have a iPhone 4 and this did NOT happen in 4.3.x...No official response from Apple on this issue yet it is very common from what I have seen on google:mad:
     
  24. iciconnect macrumors newbie

    iciconnect

    Joined:
    May 18, 2010
    #24
    Iphone 4s stops playing music and iTunes music issue

    I've notice that about every 10 songs or if it plays on it's own without advancing. It would then just stop playing music. Even when I press the screen or when I use the headset control from Apple, it will not play. Sometimes when I selecting the playlist again it would continue playing my music. But other times I must power on and off my iPhone to get it to work. Another thing I notice that drives me nuts is when I pause a song and press continue every so often it would continue with static sound or skipping or it would just stops playing the song. Has anyone jailbroken their iPhone 4s?:confused:
     
  25. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #25
    IF you restore from a backup, do yourself a favor: delete and resync ALL your music on your device. Also do this for all of your streaming apps(Pandora, Slacker, etc). Should fix the problem.
     

Share This Page