iPhone 4 photos stuck on "Saving Photo" if tried to attach/delete, etc.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by FLAVAH, Jun 30, 2010.

  1. FLAVAH macrumors member

    Joined:
    Aug 1, 2008
    #1
    Hi everyone, let me give you as much detail as possible so that my problem can be solved much quicker.

    I have an iPhone 4 that I have restored from a backup of my 3GS. Everything was working fine until I tried taking a photo. Once I took the photo, and let's say I wanted to e-mail it or MMS it, or even delete it, it would say "Saving Photo" with the progress circle, ENDLESSLY. Sometimes it would not even show up in the camera roll, and sometimes it would.

    Things I tried:
    1. Erasing the phone and setting up as a brand new phone. This worked to remedy the problem, but now I would be stuck without any of my old data.
    2. Erased and restored as a new phone, but tried dropping the backed up "3d0d7e5fb2ce288813306e4d4636395e047a3d28" SMS file, info.plist, status.plist, Manifest.mbdb,mbdx,plist, just so that I could at least recover my years of texts. The problem still persisted with the camera roll photos.
    3. Same as #2, but I tried it multiple times to narrow it down to a file that would be causing it. It seems that something in the Manifest files is causing it because if I used all of the other old files, it would still work (however the SMS files would not be restored)

    If anyone has any advice on what I can do to restore at least just my SMS files, please let me know! Everything else can be restored, I have MobileMe, etc. Thanks in advance!
     
  2. FLAVAH thread starter macrumors member

    Joined:
    Aug 1, 2008
    #2
    Solved!

    After literally HOURS of trying to figure it out, I GOT IT! So I'm going to divulge here just for anyone else who ever encounters this problem.

    Make sure to have:
    -Backup of the SMS file "3d0d7e5fb2ce288813306e4d4636395e047a3d28" that you are trying to restore to
    -Clean install and setup as new phone, then create a backup of that fresh install.

    After you have those two things, right-click on your iPhone in iTunes and restore to the backup that was having problems. Once it is restored, open up the "fresh install backup" and drop in a copy of the old SMS file "3d0d7e5fb2ce288813306e4d4636395e047a3d28" to replace the new one. Restore to that "fresh install backup" with the new file, and voila!
     
  3. puttputt macrumors regular

    Joined:
    Sep 12, 2006
    Location:
    Michigan
    #3
    I encountered this same problem on my iPhone4.

    It happened while I was trying to delete a couple of images and videos.

    I was still able to import them into iPhoto, and selected "delete originals" and it erased them (including the "stuck" ones) from my phone. The other photos on that "roll" were OK in my iPhoto library.

    I think maybe a memory error corrupted the files?
     
  4. markyboy macrumors newbie

    Joined:
    Jul 21, 2010
    #4
    Solved problem

    I had the exact same problem. I was able to google for a solution by fixing the files/directories permissions:

    Step 1) SSH into the iPhone
    Step 2) cd /private/var/mobile/Media
    Step 3) chown mobile: * -R

    I hope this helps.
     
  5. elie.fares macrumors regular

    Joined:
    Sep 13, 2008
    #5
    ^ I tried Flavah's method, it didn't work.
    I'm gonna try yours in a few minutes. But can you plz elaborate on step 3.
     
  6. markyboy macrumors newbie

    Joined:
    Jul 21, 2010
    #6
    Just type in step 3 in the command line once you root into your iphone.
     
  7. spencham macrumors newbie

    Joined:
    Aug 1, 2010
    #7
    I had the same issue on a 2 day old iPhone 4 V4.0.1 with minimal history. I connected to the computer (PC) and, after backing up, deleted all the photos in the camera roll through explorer.

    When I disconnected and launched Photos on the iPhone, the 'black box' thumbnails were displayed for the items I had deleted. When I selected one and clicked delete, a message was displayed that there was a problem with the folder (don't recall the exact message) and I should launch Photos to resolve it - it then kicked me to the home screen.

    When I launched Photos it ran through a process and rebuilt the thumbnails in the camera roll. It had found a video file that was previously undetected (through both the PC drive letter and iPhone) but I was able to select and delete without a problem.

    No problems since.
     
  8. Songstresscab macrumors newbie

    Joined:
    Oct 12, 2010
    #8
    Is there a way to SSH into an unjailbroken phone? This problem has started with me. I have visited the Apple store where they replaced my phone, they restored it on their computer updated it, etc. It was working fine for a little while and then gradually the problems recurred. I have the issue with "Saving Photo" and I also cant save any pictures from Safari or text messages. The only way to get pictures onto my iPhone is to sync it to my photo albums. I have been working via telephone with a supervising engineer who is also stumped as to why this is happening to my phone especially since they gave me a replacement. Has anyone successfully fixed this issue on a non jailbroken phone?
     
  9. EgoMagne macrumors newbie

    Joined:
    Apr 19, 2011
    #9
    I had the same problem after I updated my iphone 3g from fw 2.2 to 4.2.1
    markyboy's way did the job for me.
    thanks much.

    PS: to do that you have to jailbreak your iphone and install openssh from cydia to make your phone "connectable". Otherwise your iphone will not accept connections.
     

Share This Page