iPhone 4 SMS and MMS problem

Discussion in 'iPhone' started by sirslimjim, Jun 24, 2010.

  1. sirslimjim macrumors newbie

    Joined:
    Jun 22, 2010
    #1
    So I just got my phone today and noticed that I can't receive any SMS messages and can't send MMS (i get the red exclamation mark thing). Also, people i send text messages to aren't receiving them.

    Anyone else having this issue?
     
  2. sirslimjim thread starter macrumors newbie

    Joined:
    Jun 22, 2010
  3. blajoie macrumors newbie

    Joined:
    Jun 24, 2010
    #3
    are you coming from the 2g iphone?
    I was and had to call - they had to add a new text messaging feature ($5/month) to allow MMS/SMS....
     
  4. bigbarr macrumors member

    Joined:
    Oct 21, 2003
    Location:
    Tampa
    #4
    same problem here. I switched from my iphone 3gs. I got online and noticed that I had no text plan put on my account when i went to a family plan. I added one at that time. I also reset the network settings on my phone to see if that would help after adding texts.
     
  5. bigbarr macrumors member

    Joined:
    Oct 21, 2003
    Location:
    Tampa
  6. Love Juice macrumors regular

    Joined:
    Jun 2, 2008
  7. MisterDisney macrumors 6502a

    Joined:
    Jun 20, 2010
    #7
    No problems. But we've had unlimited shared texts with our family talk plan for a while.. Nothing to change.
     
  8. miraishak macrumors member

    Joined:
    Nov 23, 2010
    #8
    problem with mms in phone 4

    i have found a bug and i wanna know if anyone else is having this:
    when i send MMS to a contact i choose from my contact list, after teh MMS is sent, in the messages list, the MMS sent doesn't show teh contact name. instead, it shows the contact number and gives me the option to add the contact as a new contact! although it is already in my contact list. this doesnt' happen with SMS.
    details:
    iphone 4
    OS 4.1
     
  9. daudi macrumors member

    Joined:
    Jan 1, 2012
    #9
  10. patent10021 macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004
    #10
    iPhone 4 here.

    I get the red exclamation a LOT when sending photos. Every day and pretty much every time I send a photo. Gotten to the point where I'll usually send it via iOS Mail app. The weird thing is the people I MMS with the most the photos take the longest. It's like the system/carrier has a data backlog or something. My friend and I have had to wait 10 minutes for one photo to transfer. Frikkin' ridiculous. Sometimes I get lucky and can send a photo right away but this is a rare case.

    Don't know if it's an iOS 5 problem or carrier problem.
     

Share This Page