iPhone 4 w/ 4.2.1 redsn0w stuck on Apple-Logo - Boot tethered wont work

Discussion in 'iPhone Tips, Help and Troubleshooting' started by CapitalTee, Feb 10, 2011.

  1. CapitalTee, Feb 10, 2011
    Last edited: Feb 10, 2011

    CapitalTee macrumors newbie

    Joined:
    Jul 3, 2010
    #1
    Hi all,

    My iPhone 4 is on 4.2.1 jailbroken with redsn0w tethered jailbreak.
    Yesterday it crashed while doing a respring and I had to turn it off.
    It then stuck on the Apple-Logo.

    When I arrived back home I wanted to do the "Just boot tethered right now" as usual.

    Redsn0w works flawlessly and exits saying that everything went well and the rest of the process takes place on my iPhone. But the iPhone just keeps showing the Apple logo, nothing else.

    I tried different versions of redsn0w (b4, b6 and rc8). All lead to the same result.

    Does anyone have an idea how to rescue my iPhone?
    I dont want to put it in DFU and restore yet, since I dont have a recent backup and there are some valuable photos on the phone.

    Any help is greatly appreciated. This kept me up all night for like 6 hours, but I couldnt get anything to work :(...

    Edit: I even tried greenpois0n, but it just says "Jailbreak failed"... and a white screen on the phone
     
  2. mariwun macrumors newbie

    Joined:
    Feb 11, 2011
    #2
    hey i had the same problem
    force a reboot by pressing the home and power button for 10s, the phone will only go off for a few seconds before it comes back on
    make sure you have redsn0w started up and at the point where it tells you to connect your phone and make sure it is off(tick only Just booth tethered right now)

    once the phone goes off quickly press next on redsn0w and follow the steps to put it into DFU mode.
    this should reboot the phone.
     
  3. mac44 macrumors member

    Joined:
    Dec 21, 2007
    #3
    This will work.

    Open Redsnow, go through the prompts and then after you check "Boot tethered":

    1. Hold both buttons down and then click Next and then let go of bottom when next screen appears
    2. Hold top button 3 seconds
    3. Hold both buttons 10 seconds
    4 Hold bottom button 15 seconds

    Let me know if it works. Good luck!
     

Share This Page