iPhone 4 - Wifi is very slow on new modem.

Discussion in 'iPhone' started by veksin, Mar 30, 2012.

  1. veksin macrumors newbie

    Joined:
    Mar 30, 2012
    #1
    Hello everyone.

    Today, I got a new modem for my Charter ISP, it is a Motorola, and my router is a D-Link, model DIR-615. After getting a new modem, I noticed my wifi on my phone only, is very, very slow. Everything else seems to work fine though. I am, and have been running WAP on my router, and switching to WAP2 did not improve it. I have reset both my router and modem, didn't help. My phone is on iOS 5.1 and its a tethered jailbreak, but I don't that should matter because on my old modem it would work fine.

    Thanks in advance,
    veksin.
     
  2. elmo151 Guest

    Joined:
    Jul 3, 2007
    Location:
    NYC
  3. veksin thread starter macrumors newbie

    Joined:
    Mar 30, 2012
    #3
    Perhaps, lol, but I really want to have it fixed.
     
  4. veksin thread starter macrumors newbie

    Joined:
    Mar 30, 2012
  5. Arnezie macrumors 65816

    Arnezie

    Joined:
    Oct 10, 2011
    #5
    Have you done a speed test on your laptop or other device and one on your phone just to rule out slow Internet. ?
     
  6. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #6
    The modem is new but you are using a router that previously worked fine?

    I know you said you reset the router but did you just reset it an not adjust any settings to try it? Ex no security, no dmz settings and port triggering etc.

    Have you tried resetting the phone? Home + power till it reboots.

    My buddies router + modem combo will work fine on his computer but my iPhone will barely even connect too it. When I unplug it and plug it back in it works great for like a week. It's strange.
     
  7. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #7
    What's "everything else"? Post speed test results from your iPhone and a wired machine for comparison.

    Have you powercycled the iPhone?

    http://guides.macrumors.com/Help:Forum_Rules
     

Share This Page