Iphone 4 wifi SLOW!!!

Discussion in 'iPhone' started by antdawe, Jun 29, 2010.

  1. antdawe macrumors regular

    Joined:
    Jun 14, 2010
    #1
    I know this has probably been covered and I have done a quick search with no joy.

    Ever since i've had my iphone 4 i've noticed incredibly slow wifi. Its not my network as my macbook, iphone 3gs and ipad all run off it at its true speed.

    Ive done side by side comparison checks with my 4 and my 3gs, with these being the only devices connected to my network for the purpose of the check. My 3gs wins by at least 3 seconds to load up a page. And as for checking my mail its mind numbingly slow.

    Is anyone else experiencing these issues?

    for your info my 3gs is running on ios4.
     
  2. Sean9689 macrumors member

    Joined:
    Jan 14, 2008
    Location:
    St. Louis, MO
  3. nosser macrumors regular

    Joined:
    Jan 25, 2005
    Location:
    orange
    #3
    same here.
     
  4. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #4
    Well its very strange. maybe a faulty phone. Im just doing a hard factory reset now. Will get back with the results shortly.
     
  5. kr00k322 macrumors 6502

    Joined:
    Jun 20, 2010
    Location:
    Long Beach, CA
  6. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #6
    [​IMG]

    It's possible you've got some kind of bad interaction with your router. Certain routers and wifi chipsets are known not to play well with each other. This could be what's happening here.

    Is there another wifi hotspot you can test with?
     
  7. Dr Kevorkian94 macrumors 68020

    Joined:
    Jun 9, 2009
    Location:
    SI, NY
    #7
    Let me guess when u first press enter after typing the site in the losing bar just sits there. I had the same problem so I would type somthing in google and it would go fast, then type somthing in the web and it would also then go fast. Then I reset my network settings a couple times and it's fine now.
     
  8. LordOBoogie macrumors 6502a

    LordOBoogie

    Joined:
    Jun 18, 2009
    #8
    Same here. It is super fast.
     
  9. vkramer macrumors regular

    Joined:
    May 15, 2008
    #9
    I found downloading large apps from the app store would crash the download (while on wi-fi), but loading websites, and data accesing apps is fast as can be. Speed test shows 14mb/s download 800kb/s upload speeds at home on wifi- I have Airport N Extreme basestation.
     
  10. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #10
    yeah thats exactly whats happening. just done a full reset and its still the same. i'll try network settings reset now.
     
  11. Laptis macrumors newbie

    Joined:
    Apr 2, 2008
    #11
    Try turning off N on your router.. I had to do this and mine sped up.
     
  12. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #12
    I've tested it at a couple of mcdonalds, starbucks etc with no evail. My speed test app shows really fast connections but its taking for ever to load info
     
  13. synagence macrumors 6502a

    Joined:
    Jul 23, 2008
    #13
    One thing i found, is that i'd set my Airport extreme to only use the 5Ghz band for 802.11n wifi ... this is fine for my mac and other devices but the iPhone 4 (for some idiotic reason) only uses the 2.4Ghz range ...

    Oddly my iPhone4 would connect and kinda work but it was dog slow... i changed my airport to use that other band and boom! Fast wifi

    Its annoying that Apple aren't supporting the less congested 5Ghz band ESPECIALLY since Apple Airport extreme and express both support this better band

    Don't know if its the chip but my iPad supported 5Ghz fine
     
  14. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #14
    How do i do that? got a sky netgear router

    My router has 4 different options
    1. 54g auto
    2. 54g performance
    3. 54g lrs
    4. 802.11b only
     
  15. jclardy macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #15
    Hmm I am just testing my 4 vs my 3GS now on my home wifi. My 3GS constantly gets 4.5Mbps while my 4 only gets 4Mbps at its highest, averaging around 2.5Mbps in a series of 10 tests.

    My router has wireless N enabled and my Mac Mini is getting 12Mbps down. I wonder if it has to do with how the N part of the router is configured...maybe my 4 is connecting to the G part because the N is only broadcasting at 5Ghz? I'll have to check into this.
     
  16. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #16
    Right,

    I've switched to 801.11b now and it is a lot faster. however its still not as fast as my 3gs!
     
  17. ksmith80209 macrumors 6502a

    Joined:
    Aug 15, 2007
    #17
    I was having the same issue with my iPhone 4/Airport Extreme until recently. Where my MBP would get 20+ Mbps down, the iPhone would get around 2 on wifi. I found that I was using the Google DNS settings on the APE (8.8.8.8, 8.8.4.4) so I switched them to the defaults for Comcast (my ISP) see if it would help. Throughput jumped from 2 Mbps to greater than 10 Mbps on the iPhone. Your mileage may vary.
     
  18. AustinSTI macrumors 6502

    Joined:
    Jul 2, 2007
    #18
    How did you determine this?
     
  19. ksmith80209 macrumors 6502a

    Joined:
    Aug 15, 2007
    #19
    How did I determine which part?
     
  20. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #20
    Have spoke to Apple now regarding this.

    First I spoke to first line support, then senior technician and my case has now been passed to the engineers. Wow apple support sucks. They did say I may have a hardware issue. Im not so sure how they think that. anyway he said the likely hood is they'll replace it for me.

    Any UK people on here who have broadband with SKY then please let me know what your router settings are.
     
  21. SOLLERBOY macrumors 6502a

    Joined:
    Aug 8, 2008
    Location:
    UK
    #21
    So I'm not the only one. Neither myipad or iPhone 4 will connect to my sky router no matter what I try. I have searched high and low for someone with e same problem. I have the sky sagem router and my iMac, MacBook old iPhone 3G and 1st gen touch all work but the iPad and iPhone 4 don't.
     
  22. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #22
    Mine connects but with mind numbingly slow speeds. Was gonna get an ipad tomorrow but this is putting me off at the moment
     
  23. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #23
    My i4 is 5 times the speed of my 3GS. I get 12Mb/s up and down on my i4. Like greased lighting!! Love it... :D
     
  24. MisterDisney macrumors 6502a

    Joined:
    Jun 20, 2010
    #24
    I never cracked 10mbps before on my iPhone, this is amazing.
     
  25. antdawe thread starter macrumors regular

    Joined:
    Jun 14, 2010
    #25
    Thanks, this makes me feel so much better. Im going to the apple store tomorrow to demand a replacement.
     

Share This Page