iPhone 4 won't connect to home router, but connects to others fine..

Discussion in 'iPhone' started by Hephaestus, Oct 5, 2011.

  1. Hephaestus macrumors 6502

    Joined:
    Apr 4, 2010
    #1
    I moved into a rented house last weekend upon returning to university and am having some network problems.

    When I first arrived my MacBook Pro and iPhone 4 connected to the netgear router fine but I've been having problems for a while since then. On my MacBook I never get a connection instantly, upon waking up or a boot up the laptop doesn't connect. This only lasts for around 2 minutes and then it works fine. It happens every time on first launch and then works fine. But there are a few instances when it won't connect at all.

    Now, my iPhone 4 won't connect at all. I Putin the password and it connects to the router but the bars don't show and no pages load. It happens constantly with the iPhone. A restart of the router fixes these problems but several hours later it all starts again.

    I know it can't be a fault with my MacBook or iPhone since they work perfectly with other wifi points. Also 2 other people in the house say their PCs connect fine. I typed this on my iPhone via 3G which took ages.... Please help
     
  2. Rodimus Prime macrumors G4

    Rodimus Prime

    Joined:
    Oct 9, 2006
    #2
    Could be your router is max out on the number of ips it will assign. It is a setting change to increase the number it will lease out.
     
  3. Hephaestus thread starter macrumors 6502

    Joined:
    Apr 4, 2010
    #3
    The problem occurs when nobody else is using it though. I restarted the router and it's fine now, Im sure it will reappear later though. Also, I've tried forgetting the network and reentering passwords but that doesn't work. I'm also pretty sure I don't have any MAC address filtering.
     

Share This Page